Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Synapse is too limited in macro creation. Need improvement.

Discussion in 'Razer Synapse' started by Pseb_1337, Jun 29, 2019.

Thread Status:
Not open for further replies.
  1. Pseb_1337

    Pseb_1337 New Member

    Hi,

    I have a Logitech & Razer Keyboard, and I can't create macros like I want with the Synapse Razer (I tested with synapse 2 & 3).

    Example, I use in Rainbow Six these binds (I'm left handed):
    Lean Left > Alt Gr ("Right Alt" for qwerty keyboards)
    Sprint > Right MAJ (The sprint is set to Hold Down in the game settings).

    I use a Macro with Logitech software, to make these two binds in one key on the Right Alt key. If I pressed on this key, The Lean Left is triggered, if I keep down the key, I sprint. When I release the key, I stop running. Works very fine in R6.

    But with Synapse, all is broken. Nothing works.

    Picture of the macro in Logitech software => https://i.gyazo.com/c3c0c0abcffd268d0b655b79844cd46c.png
    Picture of the macro in Razer software => https://i.gyazo.com/07287f0b7937cade6c972cc06150d862.png

    Another thing, in the logitech software, we can set in an macro a down key without the release action. So, when we set the macro in "loop" as long as the key is pressed, the macro simulate the hold down for all time that I pressed the key. But impossible to do with Synapse because, we are forced to define the release of the key after the down key action. So, when I want the macro to repeat in a loop while I hold down the key, it simulates keystrokes (up and down) instead of simulating a hold down key.

    As you can see in the pictures, in the logitech software, I set two keys with key down action only. It's important for simulate a long press of these keys if I hold down the macro key. But in Razer software, it's impossible to set only the down key, we can only set a keystroke with press and release, so it's impossible to simulate a long press of the keys if I hold down the macro key. And if I try to delete the "release" action, the software delete also the down action. Very annoying.
     
    pancholr and WolfmanPatriot like this.
  2. RadamasMiami

    RadamasMiami New Member

    Im having exact same issue. If anyone knows a fix for this, a way to delete the release part of key or maybe there is a way set a delay for release that simulates it not being there . Any help would be great.
     
    Pseb_1337 likes this.
  3. WolfmanPatriot

    WolfmanPatriot New Member

    I cannot get mine to do the moves I want either. I try to make batman do a triple cape stun and another with a beatdown after the stun. I get one cape stun and then one punch no matter what I try. Either that or it does nothing. VEry aggrivating because I have a feeling I set it up correctly (If the program worked properly.) If this is so, than nothing else I am going to try will work. I have tried sequence, keyboard stroke, playing with delay times, and nothing works for me. In fact, sometimes i do a move pressing one key, then press another and the second key does the same thing the first key did.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >