Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Synapse Not Detecting Mouse or Keyboard?

Discussion in 'Razer Synapse' started by autoVeryLightBlue350, Dec 14, 2019.

Thread Status:
Not open for further replies.
  1. Hi all, this just started the other night. My razer Synapse app is no longer detecting my mouse or keyboard.
    -Razer Deathadder Chroma
    -Razer Blackwidow X Chroma
    Straight up at one point my keyboard stopped working. i put it into a different usb port and at least now i can type on it.
    I installed an update and it has done nothing to help.
    I run windows 10
    Its not giving my mouse or keyboard their chroma, they aren't even showing up in the app. sent in a support ticket, waiting for a response. If anybody has any tips in the meantime that'd be fantastic. thanks.
     
    MeeM0daz likes this.
  2. ARMOR_152

    ARMOR_152 Well-Known Member

    You might have tried the basics already but try reinstalling Synapse 2, do all the Windows updates, and restart. If that doesn't work...not sure
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >