Synapse not showing Raptor

Discussion in 'Razer Support' started by Broddoi, Mar 4, 2021.

  1. Broddoi

    Broddoi New Member

    Hi,
    Since yesterday I can't find my Raptor in Synapse so also the lighting is going independently. Monitor is connected with USB-C, I tried reinstalling software, rebooting but it does nothing.
    Monitor apart of that is working fine but I'd like to have it like it was 2 days ago, thanks for any help!
     
    Kaliax972 likes this.
  2. Kaliax972

    Kaliax972 New Member

    I have the same problem. My Raptor 27 is connected via USB Type-C directly to my computer (and also via Display Port), and even after Synapse uninstall/reinstall and PC reboot, the software cannot find it.
     
  3. Idealschiss

    Idealschiss New Member

    Same. My PC is connected via Displayport and USB Type-A. Did reinstall the software after deleting all components of the old synapse in the registry.
     
  4. geoPaleGoldbox232

    geoPaleGoldbox232 New Member

    anyone manage to fix this? I have the same issue - I've tried different usb c cable but no joy. I've plugged the usb c into my mac mini and the video signal works - so I don't think it's the cable or port. The hub features ain't working either.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >