Synapse not starting..

Discussion in 'Razer Synapse 3 Beta' started by 88DJK, Mar 11, 2019.

Thread Status:
Not open for further replies.
  1. 88DJK

    88DJK New Member

    Hello. A while ago i got a naga trinity mouse.. everything worked fine for some time.. but nowdays synapse does not start. Its been doing this for quite a while and i have no clue what to do next.. i have tried everything i've found online as a fix, uninstalled & reinstalled mouse & software, updated net framework and everything else that needed updating.. tried compatibility mode, ran as administrator and still nothing.. sometimes it does nothing when started while sometimes a small window appears that says "starting synapse" then poof.. nothing after. The processes appear in task manager (razer synapse 3 & razer synapse service) but nothing else. Razer central says synapse is not running even when the processes are started.

    This is completely unacceptable.. I have 0 utility out of this mouse if i cannot use synapse. Please help. I need a fix for this otherwise i'm just looking at a pretty mouse that has 0 utility -_-
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >