Synapse won't open (Win 10)

Discussion in 'Razer Support' started by DJSoul, Jul 13, 2018.

Thread Status:
Not open for further replies.
  1. DJSoul

    DJSoul New Member

    Hi, I've seen a few threads with this problem but no solution yet.

    I click to open Synapse and nothing happens, no error message either. Windows 10 did have an update a few days ago.

    Hopefully there's a fix as I need to change my sensitivity for different games often.

    Thank you
     
  2. Biosplat

    Biosplat New Member

    have You tried closing synapse’s background process.
    This happened to me before and I think it was because the application was open in the background so it wasn’t opening again. I fixed it by.
    1) open task manager
    2) scroll down until you see Razer synapse
    3) right click and end the task
    Hopefully that works
     
  3. DJSoul

    DJSoul New Member

    Thanks tried that and thought it was going to work as it starts and says 'syncing settings from the cloud' but then doesn't open :slightly_sad:
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Heya guys! Have you tried repairing or doing a clean uninstall of Synapse?
     
  5. DJSoul

    DJSoul New Member

    Hi, how do I repair this? I'm not even sure what version I have, I think its V2. Is there a way I can check and if so whats the best version for me? (Win 10 - Deathadder Elite / Tartarus / Firefly Hard mat / Blackwidow keyboard V2) Thanks!
     
  6. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Sent you a PM to help you out with this.
     
  7. DJSoul

    DJSoul New Member

    Thanks, I've replied.
     
  8. Napperdo

    Napperdo New Member

    same issue with BW v2, mamba TE.... could you share the PM you got about this issue please??
     
  9. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Try to repair and or reinstall Synapse and see if it helps.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >