Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Tapjoy on CORTEX Mobile Paid to Play (Silver Points)

Discussion in 'Razer Cortex' started by aiyionman, May 8, 2020.

Thread Status:
Not open for further replies.
  1. Sacius

    Sacius Well-Known Member

    I did, tried 3rd game now, and it seems to be working.. Must be a bug or something ;)
    cravenguy and aiyionman like this.
  2. aiyionman

    aiyionman Active Member

    Got the reward!
    cravenguy, FiszPL and peter76james like this.
  3. cravenguy

    cravenguy Member

    i actually have this showing on one of my offers (the coin master offer). funny to see how tapjoy works sometimes
  4. Sacius

    Sacius Well-Known Member

    Any1 else cant get any rewards? I`m launching game after downloading immediatly from offer page 1st, completed some stuff in couple of games a while ago, and it still isnt registered as completed :/ I`m doing smth wrong or it just happens knowing its tapjoy.. ><
  5. tuningislife

    tuningislife Member

    Yea. I noticed it on Coin Master as well. West Game, FoE, and GoG don't do it. Nor did SoS.

    A lot of these games are hard to get to the level to earn the Silver without spending money. Some of the offers actually require you buy something to earn silver as well. e.g. "Make a $4.99 purchase in Bingo Pop" ... well... if 1000 silver = $1 ... then you get $0.494 in silver for that $4.99 purchase.
  6. FiszPL

    FiszPL Well-Known Member

    I've got my reward too, but almost instantly.
  7. Sacius

    Sacius Well-Known Member

    Odd, I received my reward in coin master instantly, but still no rewards in candy crush and sniper 3d :/ These offers act odd sometimes I guess..
  8. kchin7

    kchin7 New Member

    I went to the Tabjoy page and it states that no offer available. How long is the reward refresh cycle?
  9. aiyionman

    aiyionman Active Member

    Still shows on my side. Try to choose Discivery and Action...
  10. kchin7

    kchin7 New Member

    Tried but luck not on my side
  11. aiyionman

    aiyionman Active Member

    Hmmm.... is your Cortex updated? Also try logging out then logging in your account?
  12. kchin7

    kchin7 New Member

    Oh, will check for update later
  13. You can email to Tapjoy customer care along with the proof. They will reply for sure and you will get your respective Razer Silver for sure if you are eligible.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >