The all-new Razer Blade Stealth 13

Discussion in 'Systems' started by Razer.WolfPack, Dec 4, 2018.

  1. Spoonablehippo

    Spoonablehippo New Member

    Razer have taken down the new BIOS update that cripples performance by the looks of it!
     
  2. Preystation

    Preystation Member

    I already have blade pro 4k with i7 7820hk and gtx 1080. I also have core v2 with gtx 1080 Ti asus tog strix. Blade pro doesn’t fully support core v2.
     
  3. rglasser

    rglasser New Member

    ...is there any way to roll back the bios and EC updates that are now taken down, without doing a system restore/deleting everything I've installed?
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    So far I know once you did EC or Bios update there’s no way back, even reinstalling windows, it’s saved on the board, similar with Apple phone iOS version update, can’t go back unless by tweaking it that voids the guarantee. Hope they are optimizing or fixing issues that users reported and it will back there soon again.
     
  5. whatthewesh

    whatthewesh New Member

    Just got mine for about a week. First impressions of the device was really good.

    Just contacted support for charging issues.
    - No charging when plugged in and powered off
    - While using normally (just simple web browsing), I noticed the charge status as "Plugged in and discharging"
    - Charging stops intermittently and I have to resit the cable

    Extremely disappointing for the amount paid for the laptop. Definitely considering returning it instead of requesting for repairs
     
  6. purplexed9

    purplexed9 New Member

    Dear Razer,

    I am really whilling to buy this laptop. But with all of the issues that have been going round, I am really considering not to, as I don't want to be the guinea pig in testing it with all of its faults.
    So, I want to ask:
    Is there anyone from your side looking into fixing these issues?
    Is the discharging something that could be fixed with a BIOS update, or is it a hardware issue that is going to be fixed in future models?
    What about the coil whine / crackling noise, is there a fix for these?

    Thanks in advance.
     
  7. WilliamTheBastard

    WilliamTheBastard New Member

    So, after a month and a half of frustration, I'd like to share my experiences.

    I first ordered a Blade Stealth mid December to use for school. Literally every single aspect of the laptop appeals to me: small 13" form factor, slim sexy bezels, entry level graphics card powerful enough for 60 FPS dota (the only game I play), decent speakers for netflix, black color, USB-C charging. I am very picky, and it hit all of the points I was looking for. Truly a unicorn.

    Unfortunately, my first unit arrived with coil whine and speaker crackling. I checked this thread, and I tried using older realtek drivers to fix the speaker crackling. That worked. Unfortunately, changing the SSD did not work. The coil whine persisted, so I went ahead and returned the unit for another one, hoping I would receive a non defective unit and be happy with a perfect laptop.

    No such luck. The second unit also had both of the above issues. Worse, its fan, when under load, emitted a high pitched whine that my first unit did not have. I understand that this is a small laptop and under load the fans must spin at high speed to dissipate the heat, but the high pitched whine was very annoying, and definitely not a feature because it was not present in the first unit. Thusly, I returned the second unit, as well.

    On to the third. The new stealth is just so perfect for my needs that I was willing to try again. I contacted support TWICE to inquire about the issues, and whether or not they were addressed. Both times, support informed me that they have been. However, my third unit possesses ALL of the above defects; the coil whine, the speaker crackling, and the high pitched fan whine. Worse, this unit now has an imperfection in the finish on the lid; a silver speck sticks out. Not only is it an eyesore, I can catch onto it with my fingernail. Each subsequent unit I received came loaded with more and more defects. Extremely disappointing.

    I have already initiated a return for the third unit. I am seriously at a loss as to my next move. I contacted technical support this time to inquire about whether or not the issues have been fixed, and of course, they told me that the issues have indeed been fixed, but I don't know whether or not to believe them. I truly want a non defective stealth as my all purpose laptop, as the design is truly exemplary. However, I may just purchase an iPad pro as a temporary solution (school involves lots of reading PDFs, and I do have a Dell Precision 5520 for typing emails and essays). Still debating and monitoring this thread.

    I did not test games and charging issues with any of my units.

    I do know Razer cares about its customer feedback. Support has been mostly helpful, if a bit slow. Furthermore, I've seen Min Liang Tan post on these forums directly asking for customer feedback, which is very encouraging. Unfortunately, unless they get their production issues sorted out, it is still a hard sell. I wish anyone dealing with these issues the best of luck.
     
  8. osirus35

    osirus35 New Member

    I have the same issues.. Mine seems to discharge a lot
     
  9. whatthewesh

    whatthewesh New Member

    Update on the discharge issue. Found the same issue on reddit about Synapse causing issues.
    I have uninstalled synapse and at this point I only seem to have to deal with the loose charging port. The weird discharging issues seem to be fixed with the uninstalling of synapse
     
  10. rglasser

    rglasser New Member

    Aaahhhhh. I just plugged my laptop in and experienced some good old not charging. Like, usb-c connection problem. Switched to the other side port and it worked. Switched back, wiggled it some, and it then showed plugged in. Hopefully this is not going to be a recurring problem.
     
    bizRoseTaupeboard753 likes this.
  11. Damnit I just check my left usb-c port and it disconnects if I move the charger slightly. I wonder if this is an issue everyone has but doesn't know until they experience it.
     
  12. rglasser

    rglasser New Member

    That exact same thing magically started happening to me last night. Was fine until then (2.5 weeks).
     
  13. Skeith_0x5B

    Skeith_0x5B New Member

    Razer have zero quality control - what do you expect?
     
  14. Droglez

    Droglez New Member

    Does anyone know if there is a way to roll back to a previous BIOS version?
     
  15. Joikansai

    Joikansai Well-Known Member VANGUARD

    No, as far know you can only update no roll back. Even you factory reset it. It’s from from previous stealth and Blade 15 experiences. Did support handle your problem?
     
  16. Droglez

    Droglez New Member

    Would it be possible to get hands on the original BIOS version to install that, in the sense, that you wouldn't be rolling anything back, but just updating the BIOS with and older version. Or is there really no way to get around this?
     
  17. Joikansai

    Joikansai Well-Known Member VANGUARD

    No so far I tried I can’t install old version, software will detect that you have newest version. Just like iOS software update. But I think the newest one always the improvement over last issues, it’s atm taken on support page, I think the revision will come soon or later.
     
  18. WoblyGoblin

    WoblyGoblin New Member

    Hi, I have seen that there is official announcement on notebookcheck site that anyone with the problems stated in the article (whine coil through speakers and discharge while gaming and sometimes not charging while turned off) should contact support for bios update.
    My question is, why didn't razer release the BIOS update on support download page? Since this problems are occurring on most of new RBS 2019?
    And should we all that have the same issue individually contact razer support?
     
  19. I just asked support for the new BIOS and EC download and they gave me the exact same BIOS and EC that was taken down which I had already installed on Jan 29th. The speaker and charging issues were not fixed with that update (for me at least, haven't seen anyone confirm it fixed for them either), and clearly it already had issues since it was taken down so idk why they would give me that same bios. They say it's the latest one they have.
     
  20. WoblyGoblin

    WoblyGoblin New Member

    We, will have to wait for a bit longer. At least razer admitted that they have issues and are trying to resolve the issues ASAP. Other manufacturers are not that fast when it comes to BIOS updates that resolves those kind of issues.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >