The Razer Raiju PS4 Controller

Discussion in 'Console Peripherals' started by technokat, Dec 9, 2016.

Thread Status:
Not open for further replies.
  1. Projektor

    Projektor Member

    What's the status on this controller? Doesn't seem to be for sale on the Razer store? Discontinued? Model refresh? Raiju Chroma inc?
     
  2. kajira

    kajira Mother of Gaming

    It has only been for sale in Oceanic and European markets at this time. Hopefully it will move into other stores at a future date.
     
  3. You have to download the link on a windows pc and start it, then hold X and D-Pad up while connecting the controller via USB to the PC.. then you can update it's firmware.. the input lag has been removed completely since I use this firmware the Razer support sent me
     
  4. Pokygi

    Pokygi New Member

    I did, but the program does not start, I do not know what to say.
    Version 1.01 starts, while v1.11 does not start.

    You missed posting the download when I opened it to some kind of error, like "Another is already running"
    I do not know what that means.

    I and SimoneR have solved the problem, now there is no longer the lag problem.
    The only thing is that version 1.11 does not open right away, the razer has to fix this thing.

    I have solved this;
    I downloaded versions 1.01 and 1.11, after you have to unzip them, both of them, after create two folders, in one you put the extracted files of 1.01, in the other insert the one of the 1.11
    After you open the folder 1.01, and take the "DeviceDLL.dll" file, just replace it with the folder 1.11.
    Then it should open.

    "Sorry if you do not understand, but it's hard to explain."
     
    Last edited by a moderator: Jul 3, 2017
    S_Chiu likes this.
  5. SimoneR.1983

    SimoneR.1983 New Member

    Same problem here (input lag), and can not start the program with the link posted before; my pc says "value cannot be null. parameter name value". Version 1.01 works just fine.
     
  6. Citrinegeodome081

    Citrinegeodome081 New Member

    How did you fix the problem? Someone at beginning says that firmware 1.11.0 it's working and now it doesn't.
    Do anyone have a firmware 1.11.0 working fine and can upload to internet?

    I think I understand what you mean.
    I modify the 1.01.0 .exe file in .zip file (so it become an archive). I extract the *.dll file and copied it.
    Same thing with the 1.11.0 firmware .exe file. Renamed it in .zip and paste the *.dll file (the one previous version) into the folder. Nothing change

    Other suggestion?
     
    Last edited by a moderator: Jul 3, 2017
  7. SimoneR.1983

    SimoneR.1983 New Member

    just do this:
    extract the file in 2 different folders, name them 1.01 and 1.11
    take file Devicedll.dll from folder 1.11 and replace the one in 1.01 ( replace it)
    launch program with CustomerFWU2Point5 from folder 1.01.

    You are welcome.
     
    bechamp82 likes this.
  8. Citrinegeodome081

    Citrinegeodome081 New Member

    But if you do this it start the 1.01.0 firmware upgrade anymore (even if you change the *.dll file from the 1.11.0 version). Are you sure about that?
     
  9. SimoneR.1983

    SimoneR.1983 New Member

    Try it out. This worked for me and Pokigi.

    folder should be like this
     

    Attached Files:

    Last edited by a moderator: Jul 3, 2017
  10. Citrinegeodome081

    Citrinegeodome081 New Member

    I can confirm it's working! Is strange that i tried out to update the firmware 3 times because it failed the first two times (failed in difference steps).

    Third time was the final and its done. No more lag. Played 2 hours with raimbow six siege on ps4.

    (Grande simone)
     
  11. Needfor940_no_id

    Needfor940_no_id New Member

    Hello
    Some days ago I bought a new controller and I have a problem.
    When I am playing R6 the stick random shoot one and the stick pulls up

    Have anyone the same problem?
    Or it s just an specific problem?
     
  12. SimoneR.1983

    SimoneR.1983 New Member

    Try to update the firmware to 1.11
     
  13. Needfor940_no_id

    Needfor940_no_id New Member

    Unfortunately, this did not solve the problem either :// :slightly_sad:
     
  14. I also updated to 1.11, but the problem still persists. When aiming in FPS games the movement with the analog sticks is just not smooth enough. My aim doesn't freely move side-to-side and up and down, but instead jolts in each direction, making pinpoint precision impossible.
     
  15. dalkiranoglu

    dalkiranoglu New Member

    Hi my left trigger stop deeper then right trigger stop is that normal? And left analog stick little creakiness. its only one day old.

    When i open and close triger stop afew times its seems equal now analog issue does not bother me right now its happen because anolog circle is spin not big deal for me
     
    Last edited by a moderator: Jul 10, 2017
  16. Robertopisanu

    Robertopisanu New Member

    simone non ti dico che ti prego in ginocchio ma poco ci manca, ti prego, no riuscirò mai a dividere mettere dentro e fare sta roba, inviami il file v1.11 fatto bene, TI PREGOOOOOO
     
  17. Kh._no_id

    Kh._no_id New Member


    I have Razer Raiju Controller when i play BF1 and another shoter games ,there is lag in my controller I don't know why ! Can you help me ):
     
  18. banjo818

    banjo818 New Member

    Just wondering if there is word of the coming to the U.S.?
     
  19. Saldier

    Saldier New Member

    Hello guys,
    I have two little questions. I'm thinking about to buy this ps4 razer raiju controller for FIFA 17/18. Could you maybe tell me if it makes sense to buy for this type of game this controller? Can it help to imrpove your gameplay maybe?
    I don't know how to describe this second question really good in english, but can this razer raiju controller give you a better gaming feeling in general, compared to a normal ps4 controller?
    I hope you can help me :)
     
  20. Pokygi

    Pokygi New Member

    The razer raiju pad does not work in cod beta ww2, basically the beta does not recognize the r2 key.
    This pad should have been created with the sony so that it works properly on ps4 for all games, but apparently it does not seem.
    I hope it is a beta problem and that it resolves soon.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >