Thunderbolt 4 Chroma dock has unreliable USB

Discussion in 'Razer Support' started by lminer78, Aug 5, 2021.

Thread Status:
Not open for further replies.
  1. lminer78

    lminer78 New Member

    I just got a new Thunderbolt 4 Chroma Dock for my 2019 Razer Blade Advanced. I have the dock plugged into a monitor via thunderbolt. I also have three peripherals plugged into it via usb-a. I'm finding that the performance over USB-A is very unstable. For example, if I plug my keyboard into the dock, the keyboard will occasionally malfunction mid key-press, leading to that key being repeated twenty times. Similarly, if I plug in my DAC, the sound is really terrible, as if it has a poor connection. However, if I plug these peripherals directly into my Razer blade, everything works fine. I've already tried a wipe and clean reinstall of windows, along with reseting thunderbolt, etc. Any ideas about what might fix this?
     
    jimmygu likes this.
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Have you tried replicating this behavior by connecting the Thunderbolt 4 Chroma dock to a different USB port or computer? And yes, the dock could have been underperforming and affecting all its connected peripheral. Please submit a case to our Support Team or send me a PM so I can help you generate a ticket. I'll be locking this thread now. Let's continue our conversation privately.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >