Thunderbolt port not working on razer blade 2018

Discussion in 'Razer Support' started by jason_nguyen, Dec 21, 2018.

Thread Status:
Not open for further replies.
  1. jason_nguyen

    jason_nguyen New Member

    I just got: https://www.amazon.ca/gp/product/B01M4J1DDP/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

    When I plugged it in it first froze my computer. Then I tried turning off thunderbolt security in bios. I managed to be able to have it plugged in without freezing my computer. None of my usb devices show up on the computer while plugged in through this dongle. Then I tried disabling discrete thunderbolt support in the bios. Still no dice.
     
  2. Cory_Rosenberg

    Cory_Rosenberg New Member

    I'm having the exact same issue. Did you figure out what was wrong? None of my usb 3 hubs work on my Razer Blade...
     
  3. MontyA

    MontyA New Member

    Have you checked to see if any other devices with a USB 3.1 work in these ports? If they do it may be an issue with the Amazon Product, not the system!
     
  4. Cory_Rosenberg

    Cory_Rosenberg New Member

    All the usb ports work correctly except for the thunderbolt 3 port. The port supplies power but does not detect the SD card or usb key via the connected hub.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >