Thx playback device is gone

Discussion in 'Razer Support' started by retrothinkMagentaDye756, Dec 18, 2020.

Thread Status:
Not open for further replies.
  1. I just updated razer synapse 3 to 3.5.1215.121019
    Now my THX playback device is gone after a restart. It's not in device manager and I checked if it is was disabled. It's like I never that option.
    I'm using Nari Ultimate
     
  2. Okay weird so I repaired the software, and at 35% repaired I got THX back. Then during the rest of the fix, it broke again. I restarted since it asked to and now THX is gone again.
     
  3. I fixed it by just uninstall Synapse and using the setup I used a month ago
     
  4. 0x3f8

    0x3f8 New Member

    Same symptoms here though I haven't tried loading an older version yet. Sound still comes through when set to Game instead of THX. At least that's a work around while I'm not focused on a game where it matters.
     
  5. Schredderr

    Schredderr New Member

    Mine is gone too, reinstall does not help. Any advices?
     
  6. My solution was just to send back the headphones and get wireless headphones without the gimmicks.
     
  7. Schredderr

    Schredderr New Member

    Well, that will do it too :D

    But here is a solution I figured out that worked for me:

    Steps:
    1. Uninstall Razer Synapse
    2. Download and start Release DriverStore Explorer v0.11.64 · lostindark/DriverStoreExplorer · GitHub
    3. With the Driver Store Explorer delete all Razer Audio and THX drivers
    4. Restart pc and install Synapse
     
  8. Doanvanhoa91

    Doanvanhoa91 New Member

     
  9. 0x3f8

    0x3f8 New Member

    Just an update that it's gotten worse. After the last windows update and un-announced reboot I've lost game mode as well. I've gone through the whole modify install and repair option they suggested and that didn't work. So now I guess it's a full uninstall/resinteall to see if that works.
     
  10. 0x3f8

    0x3f8 New Member

    Gust gave this a try and it doesn't seem to have worked even after all the reboots. :slightly_sad:


     
  11. 0x3f8

    0x3f8 New Member

    For what it's worth, here's where I expect the source of the problem is at.


    THX Spatial - Synapse
    Device ROOT\THXVAD\0000 had a problem starting.
    Driver Name: oem94.inf
    Class Guid: {4d36e96c-e325-11ce-bfc1-08002be10318}
    Service: sTHXVAD
    Lower Filters:
    Upper Filters:
    Problem: 0x15
    Problem Status: 0xC00000BB
     
  12. 0x3f8

    0x3f8 New Member

    So scratch that idea. Managed to get THX working again after several reboots and disabling and re-enabling each device. The most recent logs still show the THXVAD device failed to start
    Current settings are:
    Razer Audio Controller - Game: Enabled
    Speakers / THX Spatial - Synapse: Enabled
    Internal AUX Jack / THX Spatial- Synapse: Disabled

    Guess we'll see if this persists after the next reboot.
     
  13. Pummelinho

    Pummelinho New Member

    0x3f8 likes this.
  14. 0x3f8

    0x3f8 New Member

    Glad you got it working. I'm cautiously optimistic that I have mine working as well again. Razer Support reached out to me and worked with me to resolve it using THIS KB article.
    It still took an extra reboot but I haven't been able to duplicate the original issue. I think there are a couple of steps in the article that I never tried such as NOT logging into razer immediately and instead letting it go through setup as a guest. The process with DriveStore explorer is certainly less steps but if it doesn't work I recommend the official KB.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >