THX playback device not detecting on BlackShark V2 Pro

Discussion in 'Razer Support' started by Dovydas5, Jan 22, 2021.

Thread Status:
Not open for further replies.
  1. Dovydas5

    Dovydas5 New Member

    Hello everyone,
    So I recently got BlackShark V2 Pro and THX sounded muffled and I decided to try to uninstall Synapse 3 and reinstall it again. And when I reinstalled it shows that "Alarm" symbol next to headset. It recommends to change default playback device to THX. Whenever I press it, it doesn't do anything. And now it doesn't even show THX in my audio mixer or anywhere else. On second pc it's working fine, so it's something with computer problems.
    1.Any fix?
    2. Is it worth to use THX and does it sound muffled?
     
    TakeTakezou likes this.
  2. TakeTakezou

    TakeTakezou New Member

    1. I removed the driver "thxvad2" from the Windows Driver Store and then reinstalled Synaps3. I wish you good luck.
     
  3. ginzo98

    ginzo98 New Member

    did this work? how can i open the windows driver store ?
     
  4. ginzo98

    ginzo98 New Member

    I actually found the file, and was it only using these 2 steps? thanks
     
  5. TakeTakezou

    TakeTakezou New Member

    I used an application called "DriverStoreExplorer" and removed the driver "THXVAD2". Then I did a repair installation, I confirmed that a Windows playback device named THX Spatial Audio appeared.
     
  6. ginzo98

    ginzo98 New Member

    you saved me sir thank you, it worked.
     
  7. TakeTakezou

    TakeTakezou New Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >