THX sound app will not open

Discussion in 'Razer Support' started by blackdeth59, Aug 22, 2020.

Thread Status:
Not open for further replies.
  1. blackdeth59

    blackdeth59 New Member

    About two weeks ago I was using the Razer THX spatial audio app perfectly fine until either a windows update or an update to the Spatial Audio software happened. Now it will not open and in the Windows audio settings, when I choose THX Spatial, no sound is put through and I could only use the sound from my realtek speakers. Is there some kind of fix coming or is this a problem a lot of people are having? If there is a solution to fixing this, could someone please let me know?

    Thanks.
     
  2. Edebub

    Edebub New Member

    i have the same Problems. ALso if I open the App it navigates me trough some windows and there is nothing to choose from and I am Stuck
     
    SecretzW, Trivolution and pancholr like this.
  3. blackdeth59

    blackdeth59 New Member

    So the app does open for you? Are you able to mess with EQ settings and THX profiles? Mine does not open at all but it is running in the task manager. What version of Windows are you running?
     
    pancholr likes this.
  4. effectziggs

    effectziggs New Member

    i have also some problems with thx spatial.
    rn i am using razer nari ultimate game as my sound.
    but i rather use the thx spatial.
     
  5. blackdeth59

    blackdeth59 New Member

    Is the software at least opening for you? That is my problem. It just will not open or sound will not play if I choose THX spatial from the sound properties.
     
  6. effectziggs

    effectziggs New Member

    I dont have the software i think but in sound options from Windows 10 i can put thx spatial as my sound and rn it does not work.
     
  7. Rhythmcoastfresh798

    Rhythmcoastfresh798 New Member

    PHP:
    1000000000
     
  8. Trivolution

    Trivolution New Member

    me too! its so frustrating
     
  9. illkid69

    illkid69 New Member

    Which version of Windows 10 that you are running currently?
    I've upgraded to Insider Preview recently and Razer Sound not working - it did not launch at all - then i gotta rollback to previous version of Windows and the app only works properly.
    Windows 10 version 2004 build 19041.450
     
  10. fastFlamewatch909

    fastFlamewatch909 New Member

    Does anyone figured this out already? I just bought a razer blackshark v2 SE and my thx tab look like this on the photo. I can't change anything.
     

    Attached Files:

  11. sharpDeepRuby407

    sharpDeepRuby407 New Member

    Try uninstall and re-install? Maybe can make a gif to show how the problem looks like.
     
  12. JukEboXAuDiO

    JukEboXAuDiO New Member

    I am having the same problem. I am only getting sound out of Headphones Game & Chat but nothing out of THX Spatial Audio when selected.

    I have tried restarting the THX Service
    I have tried reinstalling the software to the latest version.
    Nothing. Razer how do I fix this?
     
  13. sharpDeepRuby407

    sharpDeepRuby407 New Member

    From Synapse, check if there has warning icon (next to the profile field) on the headset. Try to set the default headset in Synapse
     
  14. JukEboXAuDiO

    JukEboXAuDiO New Member

    There is no warning icon. Also Changing the volume doesn't do anything with the device set to THX Synapse.
     
  15. Zip_O

    Zip_O New Member

    it is so nice to spend $100.00 dollars for some thing that don't work. work 1 day now nothing
     
  16. MrBlaBlak

    MrBlaBlak New Member

    Uninstall razer synapse completely
     
  17. I have the same issue. Worked fine during my "Trial". Liked it and bought it. cant get it to open at all. Setup was fine. i can run the setup and it shows and goes through settings fine.But, once i close the app it doesnt open again. Also, the "speakers - THX" device doesn't work. Ive done a uninstall once and about to do it again and delete rogue files and services and throw in reboots at each stage. Ill let you all know.

    Side question. I have a Speakers THX device and a "Speakers THX Spatial Synapse" any idea why 2 services\devices. Guessing the Synapse targets just Razer products that come with it. I use both Razer and Corsair headsets. I really liked the THX on the Corsair Virtuoso the 1 time i got it to work.
     
  18. Ok, did a complete uninstall. wiped directories and such. two clean reboots. Nothing left over. Reinstalled. Noticed it still wont let me change location of the install. It installed and i went through setup. all seemed fine. Reboots. Will NOT open at all. So i tried to open it with admin access specifically forced. It opened right up. Several= re attempts and reboots. Same process. If i right clisk and run as administrator - it does open up.
    I noticed that their Cortex app had the same issue of needing specific admin access to run\load.
     
  19. dieterverberck

    dieterverberck New Member

    Hi , I have a sort of a problem with my thx app for windows
    I install the app but the thx driver will not install
    The driver will not show up in my systems default playback device but the software show up
    I reinstalled synapse and have windows 10 version 2004 build 19041.685
    What can i do?

    Tnx
     
    Bilaty likes this.
  20. Bilaty

    Bilaty New Member

    I have the same problem, it worked fine until a couple days ago and it still not work
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >