Type C Port stopped functioning.

Discussion in 'Razer Support' started by S0mth1n, Mar 12, 2019.

Tags:
Thread Status:
Not open for further replies.
  1. S0mth1n

    S0mth1n New Member

    My laptop is the 2019 Blade Stealth 4K version and I love its mobility and power. However, aside from the static noises, a more concerning issue occurred. After using the right side USB C port for charging once, it stopped working. I have tried cleaning the dust and holding the adapter onto it, but there was no response. I also checked device manager for driver issues, none. There isn't any major looseness.
    Please Help
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    By not working, do you mean it no longer allows data transfer and power? What devices have you tried to use to test the port and can you put up a screenshot of how the USB tab looks like in your Device Manager?
     
  3. Mythshot

    Mythshot New Member

    I am having a similar issue. My USB C port was working 2 days ago but now it does not recognise my SSD sandisk extreme the same drive I used 2 days ago. I have used the same cable with a USB 3.0 attachment and my laptop recognises this and loads it in the file explorer. I have also used the cable to plug in my Pixel which does show that it is charging however it does not load in file explorer.

    I am using a Razer blade 15 2019 RTX 2070 1080P UK model.
    The screen shot of the USB page in device manager looks the same if the SSD is connected via USB C or 3.0 and also when disconnected. See below.
    upload_2019-3-13_4-14-59.png
     
  4. S0mth1n

    S0mth1n New Member

    Yes, it does not allow data transfer and charging. Also, the left port only works when I use it for charging, when I apply a adapter to it, sometimes it doesnt get through.
    Do you mean the ones here?
     

    Attached Files:

    • USB.PNG
      USB.PNG
      File size:
      8.5 KB
      Views:
      5
  5. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @S0mth1n and @Mythshot, can you both send me a PM with the serial number of your Razer Blades along with the current Build Number and BIOS version? I'd like to see if I can replicate the issues here on my end.
     
  6. saddaddytm

    saddaddytm New Member

    Yeah the same exact thing had just happened to my type c, it wont recognize anything that I plug in. Although about a week ago when I plugged in the same Sandisk external SSD it worked and now isnt.
     
  7. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Has there been a significant change to your system before the port stopped working? Can you send me a PM so we can troubleshoot?
     
  8. Tone4k

    Tone4k New Member

    I've now had the USB-C port die twice. Seems to happen when I have a drive plugged in and the drive getting disconnected without it being properly ejected.
    The first time it happened, I got on Razers online live chat support and they told me to reinstall the thunderbolt driver which is found on the Razer website. That didn't fix the problem.
    I fixed the issue the first time by re installing the Razer Intel chipset firmware.
    Today, the same thing has just happened again. It's not just the drive that wasn't ejected that doesn't work, the whole port gets immobilised. Power runs to it, but no usbc device with work.
    I rely on my Razer for data management and this is a major flaw. Surely I don't have to keep reloading firmware just to get a port to work.
    What's the issue Razer?
    Love my Razer Blade 15 Base, but this issue is really unacceptable. Any chance it can be fixed permanently somehow?
     
  9. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Because you already interacted with our Systems Team, I'll need to check your case number so we can skip all the troubleshooting they went through with you. Please send me that through a PM so I can help you out.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >