Ubuntu 17.10 on Razer Blade 2017 FHD gtx1060

Discussion in 'The Linux Corner' started by mdaly001, Oct 20, 2017.

Thread Status:
Not open for further replies.
  1. mdaly001

    mdaly001 Active Member

    Hey was hoping some folks were as foolish as I to install 17.10 on the blade. I was previously on 17.04, which worked flawlessly, and yesterday removed 17.04 and clean installed 17.10. Now I have a slew of issues. It is hanging on shutdown, wireless is randomly cutting out (this part is happening on my razer blade stealth with 17.10 as well) and getting login loop when nvidia prime is switched to intel.

    Anybody got 17.10 working stable? I will be updating this thread as I troubleshoot.
     
    amarok-blue likes this.
  2. mdaly001

    mdaly001 Active Member

    RazAlgethi and kodenkm like this.
  3. skg000

    skg000 New Member

    Hey mdaly001,

    I'm about to start putting 17.10 on the blade as well. To me it looks like you have the following issues:
    1. hanging on shutdown
    2. wireless randomly cutting out
    3. login loop when nvidia prime is switched to intel
    It seems that issue 2 has been solved, any luck on 1 and 3? If not, I too will start working on it and will update this same thread with any results. Hopefully we can come up with a working guide/build for everyone when this is through!
     
  4. mdaly001

    mdaly001 Active Member

    So I gave up and just put 16.04 on it. I was running into some other issues like repositories not updated for 17.10 that was breaking some stuff i needed for work. I might be down to partition a small part of my hard drive to try to re-install so we can get this figured out. I really liked what they are doing with 17.10.

    I did end up fixing the hanging on shutdown but I had to constantly stay on nvidia prime which was a battery killer. The loop on intel was still persistent. I imagine they will have it fixed in an update but couldn't wait.
     
  5. skg000

    skg000 New Member

    Well, @mdaly001, it's the weekend now, so I'll give it a shot tomorrow and see where it goes.
     
    mdaly001 likes this.
  6. mdaly001

    mdaly001 Active Member

    Sounds good. One thing i forgot to add. I was able to get it to suspend when lid was shut but there was an issue when waking from suspend. After a couple of seconds it would suspend and then unsuspend... it looped like that until rebooting.
     
  7. ticianolage

    ticianolage New Member

    This bug is tracked in the Razer Blade page of Arch Wiki. I think you could try to apply the same solution with Ubuntu. Find it here.

    Could you please confirm me that the webcam is perfectly working with Ubuntu?
     
  8. skg000

    skg000 New Member

    this can be solved by:

    1. open /etc/default/grub with your favourite editor.
    2. Find the line "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    3. Edit and add button.lid_init_state="open" (so it looks like
      • It should look like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash button.lid_init_state=open"
    4. run sudo update-grub

    In terms of 17.10, I got everything up and running apart from that. The tricky part was nvidia drivers. Remember guys, always turnoff secure boot first from the bios, that will save a lot of your problems. After having turned off secure boot, use the "additional drivers" tool and use the GUI to install the nvidia drivers. It really simplifies the installation process. Also remember to install the intelmicrocode drivers. After that, you should have a stable system.

    I messed around with 17.10 before going back to the LTS though - wayland was having a lot of issues and CUDA and stuff works better on 16.04 currently.
     
  9. mdaly001

    mdaly001 Active Member

    Can you expand on what issues wayland was having?
     
  10. I'm having the exact same problem, any idea how to stop the hangiong shutdown problem ?
     
  11. mdaly001

    mdaly001 Active Member

    My solution was to install 16.04 haha
     
    greatGambogevalley379 likes this.
  12. lologarithm

    lologarithm New Member

    I found nvidia-settings -i lets you launch the nvidia settings panel even when running wayland.
     
  13. murder_t

    murder_t New Member

    The hanging shutdown seems to be caused by using the nouveau video drivers. Install the Nvidia drivers and shutdown should process as expected.
     
  14. rmasclef

    rmasclef New Member

    Hello there, it's been a month now since I bought the Blade and installed Ubuntu 17.10 and I've been struggling to make this OS work properly.

    As a previous macOS user, I really loved the touchpad gestures and was searching for a way to have it on linux ... and I found it :) (https://github.com/iberianpig/fusuma).

    At this time, there is only ONE thing that is REALLY driving me crazy and its name is the pointer/cursor dropping randomly.

    This bug seams to be there for a while now and I did not find any post talking about a resolution.

    FYI I'm using the 4.15.5 kernel (latest stable one) and I don't see any difference :/
    I also installed https://github.com/iberianpig/fusuma in order to get more trackpad multitouch gestures (it uses XORG as display server).

    Is this bug present on 16.04 LTS ? (that might help me know if I should install it instead of keeping 17.10 version).

    Thanks for your help !
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >