Ubuntu installation fails with "grub-efi-amd64-signed failed installation" (Blade 15 2018)

Discussion in 'The Linux Corner' started by RandomUntilSuccess, Dec 1, 2018.

Thread Status:
Not open for further replies.
  1. RandomUntilSuccess

    RandomUntilSuccess New Member

    Hi,

    I tried to follow the tutorial from https://qiita.com/taketomatsunaga/items/ee5c0fbed7d438d41e1e but nevertheless I ended up with the ""grub-efi-amd64-signed failed installation"

    With a little bit more searching, I have now in the order: recovery partition / an EFI partition / the windows partition / swap partition / ext partition / Winre partition.
    By trying installing it again, I still hit the same failure.

    I know that Ubuntu is installed on the ext partition and I think to know I need to do something with the bootloader.

    Here my problem, when I pay so much money, I actually do not want to mess around with the boot system. I did it already with other Pcs and something ended up not working as expected: battery consumption high, device not waking up after deep sleep, etc...

    Does one of you smart people has an idea what I should do?
     
  2. after-life

    after-life New Member

    It's really not as involved as that guide suggests.
    1. Update bios from Windows.
    2. Create Ubuntu USB.
    3. Shrink Windows C drive using Window's own partition tool (don't need to install any other software for this).
    4. Disable Secure Boot in bios.
    5. Boot from Ubuntu USB and select "Install alongside Windows" (it should just install on the free space).
    6. Follow the prompts.
    Head over to the Linux Blade Discord if you would like more help on this.
     
  3. RandomUntilSuccess

    RandomUntilSuccess New Member

    Hi @after-life,
    Thanks for the info. The only step I forgot was 4. Nevertheless, it still doesn't work...
    I will join the Linux Blade Discord like you recommend. There I will also post a pic of the error log.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >