UEFI & Dual Boot on the Razer Blade Pro FHD 2017

Discussion in 'Off Topic Chat' started by thephilip, Apr 5, 2018.

?

Was this helpful?

  1. Yes

    0 vote(s)
    0.0%
  2. STFU

    0 vote(s)
    0.0%
Thread Status:
Not open for further replies.
  1. thephilip

    thephilip New Member

    I had a little trouble getting a dual-boot configuration going on this thing, so I thought I'd share what steps I took to aid others that may run into this issue. I'm a fan of Manjaro (Arch-based distro; GNOME edition) and was able to successfully boot the thumb drive with the live installer and install. I'll make this less wordy (a tldr version, if you will), but will be happy to answer any questions or take any advice.

    0. Right-click the Start Menu icon and open Disk Management to shrink your Windows (c:) volume. I allocated 40GB because I typically use Linux for programming and basic stuff and I use the 2TB drive for shared, permanent storage anyway. This also leaves me space for games that I frequent in Windows so they can load fast on the NVMe.

    1. Create UEFI-compatible USB boot disk (I used USBWriter on a Windows machine, but you can use dd or whatever you like).

    2. Boot off the thumb drive and verify you've booted in UEFI mode:
    # [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

    3. Install as usual (remember to mount / and /boot/efi (/dev/nvme0n1p2 for me), but do not format the EFI partition so you just add an entry to it instead of blowing it out.

    4. At this point, I was able to boot the NVMe install via the live disk, but you can stay live an chroot into your install if that's easier for you.

    5. Boot into the installation and find out where you EFI partition (esp) is and the NVMe device name:


    6. Install the package 'efibootmgr'. To view what boot managers are available in NVRAM, run `efibootmgr` or `efibootmgr -v`. This will show you the currently booted entry, the boot order, and a list of the entries.

    7. I tried to get this working multiple times. I could get an entry to show up, but when I tried loading, it'd "flash" the screen and it'd re-load the boot options screen. The only way I could get Linux to boot was by putting the grubx64.efi file into the Micro$oft boot directory:
    # cp /boot/efi/Manjaro/grubx64.efi /boot/efi/EFI/Microsoft/Boot/.

    8. Next, add the entry in NVRAM (https://wiki.gentoo.org/wiki/Efibootmgr):
    # efibootmgr -c -d /dev/nvme0n1 -p 2 -L "Not Windows" -l "\efi\Microsoft\Boot\grubx64.efi"

    9. Reboot and viola!

    I hope this helps someone.
     
    hector_tk, kcutler and Joikansai like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >