Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Unable to get THX-Spatial - Synapse with Razer Nari Ultimate.

Discussion in 'Razer Support' started by AshRizim, Jun 30, 2019.

Thread Status:
Not open for further replies.
  1. AshRizim

    AshRizim New Member

    So when I connected the wireless dongle to a USB port on my pc, everything works fine. But when I remove the dongle and connect it to a USB port on the Razer Base Station Chroma (headset holder) it doesn't work under THX. And reverts back to Headphone (Razer Nari Ultimate - Game).

    Tried rebooting, removing the devices from control panel with no success. Anyone else experience this?
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    I have simmular issue for me simple reinstall of synapse fix the issue. It's annoying but do the job.
  3. ShaguarWKL

    ShaguarWKL New Member

    I am experiencing a similar issue. I am using the Razer Base Station and Nari Ultimate. Keyboard is Huntsman Elite

    It all started when I changed the following when I realised the Base Station wasn't plugged into a red USB port on my machine because I came home to a still battery dead Nari after 8 hours (it was working when I first got the Nari and I only now realised that I had my phone plugged in when I shutdown my machine and it was still pulling current so the Base Station was still sending charge to the Nari which was also plugged into the Base Station. This time around, I shut down only with the Nari plugged in and turned off prior to shutdown. Changing to the Red USB port on my machine started all my other problems. The dongle is also in the left most port of the Base Station.

    Speaker (THX Spatial - Synapse) no longer output sounds, but if I switch to Headset (4 - Razer Nari Ultimate Game) then sound comes back. I'm not sure if THX works outside of Synapse but the testing gave surround sound inside Synapse.

    I've tried rebooting and restarting the services to no avail. Reinstalling Synapse fixed the issue.
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Are you still having this issue? Let me know.

    ~Moving this to the support board.
  5. BoboDigital

    BoboDigital New Member

    I have absolutely the same issue and was not able to fix it so far. Any ideas?
  6. BoboDigital

    BoboDigital New Member

    I tried reinstalling Synapse and updating it to the latest version - it did not help.

    There is no sound in the headset when I choose THX Spatial - Synapse or Razer Nari Ultimate-Game from Windows 10 sound settings. The sound returns only if I choose Razer Nari Ultimate - Chat as default communication and sound device. Moreover, I do not hear any sound when I try to calibrate THX from Synapse.... Yesterday everything worked fine, I have not made any changes to settings or anything else. I have no idea where the problem is coming from.

    Please support!
  7. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Was this working before? When did this issue start?
  8. Frijoles.-

    Frijoles.- New Member

    I have the same issue it was working before and it doesn't make noise on thx mode. it started about a couple of days ago
  9. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Please PM me the serial number of your Nari as well as a screenshot of your audio settings. I'll pick it from there.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >