Unable to rebind keys properly (OS X)

Discussion in 'Razer Synapse' started by lynxie, Jul 13, 2017.

Thread Status:
Not open for further replies.
  1. Hey guys,

    yesterday I got my BlackWidow Chroma V2 but I am not able to rebind keys as I like due to strange behavior.

    When I click on any Key inside Synapse the "BUTTON ASSIGNMENT" window opens as it should, but as soon as I click with my mouse ANYWHERE (and also on the okay button) the field "Rebind key to" changes to "Left Control + Left Shift + Left Alt + Left Command + R..." :/

    I also have to hit the key I want to rebind to twice to show up in the field. After that I just need to hit a key once to show up. I have to hit twice again after I clicked the mouse once. That shouldn't be the case either.

    OS X Sierra (10.12.3)
    Razer Synapse 1.7.2
    Logitech G502 mouse with Logitech Gaming Software installed (8.92.37)

    What I already tried:
    1. Change user of OS
    2. Quit the Logitech Gaming Software (Of course I don't have anything else mapped on left mouseclick than left mouseclick)

    On a MB Pro with 10.11. installed + G502 key rebinding worked fine.
    Should I try to deinstall Logitech Gaming Software? (This sadly wouldn't be a solution)

    Do you have any other ideas or hints what I should try to resolve this or where this is coming from?


    Thanks in advance!

    I just tried to record a macro and a click with the mouse gets me this result.
    What is going on here?!
     

    Attached Files:

    Last edited by a moderator: Aug 2, 2017
  2. PT.Singer

    PT.Singer Jedi Master

    Razer Support. Razer Suport.

    First port of call - Razer Support (just look in my sig for the link).

    MY first question - have you tried a different mouse, just to see what happens? A non-customizable mouse (or at least one that doesn't have its own software to customize it, like I would assume the Logitech mouse would)?

    When Sierra came out, the first thing that drastically changed for me and my Razer Naga Epic Chroma and Synapse was a lack of being able to use the left-click in a macro. I used to have buttons on my Naga that were assigned to Shift+Left Click, Control + Left Click, Command + Left Click, etc. They all stopped working with Sierra.

    There are some things that Sierra just broke in Synapse with Mac. The scroll wheel speed and lack of left-click macro assignments are just two of them.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >