[UPDATE] Razer Blade 15 ft. Intel 9th Gen processor

Discussion in 'Systems' started by Razer.WolfPack, Jan 6, 2019.

  1. AntsaK2

    AntsaK2 New Member

    Ok Thanks!

    My next issue is that my 1070 which is connected via Mantiz Venus eGPU won't work. Device manager sees it as a Microsoft Display adapter. When I delete those drivers Windows will recognize that it is GTX 1070 but can not automatically install drivers. If I download those drivers manually from Nvidia I get message that those drivers are already installed.

    I am out of ideas.
     
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    Why do you want to connect 1070 egpu, your 2070maxq performs better than 1070 TB3 egpu setting, it’s bottlenecked by TB3 bandwidth and cpu. Probably you’ll get some advantage with egpu setting if using 2080ti. Anyway first connection may take a bit time until system recognize it well, plug it and wait a moment maybe up to 5 minutes. Idk if it’s compatibility issue with mantiz but on Razer Core first time usually take longer than after recognizing, you don’t have to download new driver if your laptop use newest one already, I think 1070 latest driver is same with 2070maxq one.
     
  3. AntsaK2

    AntsaK2 New Member

    Well I'm currently using Mantiz as a glorified USB Thunderbolt hub but I had to test that GPU in there works with Balde.

    The problem was solved by disabling 2070 from device manager and after rebooting Windows recognized 1070 automatically.
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    Yes it should come at first. Try Razer gpu switcher, maybe it compatible with Mantiz, a lot easier switching the gpu.
     
  5. HYUK88

    HYUK88 New Member

    Razer Blade 15" 2019 BIOSv0104 & EC Updater v0103 update today.
    EC Update fine but Bios Installation stops at 99%.
    Does anyone know how to update bios manually?
     
    Last edited: Apr 10, 2019
  6. Preystation

    Preystation Member

    Mine installed in seconds.
     
  7. Any idea what the new BIOS and EC offer?
     
  8. Preystation

    Preystation Member

    Really?
     
  9. Same problem here. BIOS update hangs at 99%. Did you install the ME firmware update released earlier this week? I did. Makes me wonder if their BIOS flash program wasn't updated to account for those changes. I have a support case open. We'll see what happens
     
  10. HYUK88

    HYUK88 New Member

    yes. i did ME firmware update this week.
     
  11. Mannymal

    Mannymal New Member

    Can someone test Windows Hello in the dark? As in, completely dark room and a dark wallpaper in your lock screen? With my Surface Book 2 it will detect your face no problem thanks to the the IR blaster, but with my RB15 there has to be at least some light for the camera to see you. I wanna know if there is something wrong with my laptop or if its a limitation of this Windows Hello implementation.
     
  12. crypticc

    crypticc New Member


    Interesting that the new EC firmware apparently addresses "audible motherboard noise"

    Anyone tried it yet can comment on the noise?

    C
     
    Last edited: Apr 14, 2019
  13. crypticc

    crypticc New Member


    Did you install bios first or EC update first? Unlike ME firmware update there's no indication on Razer site which should go first
     
  14. secludedhydrangea

    secludedhydrangea New Member

    I'm having the same problem too. I also installed the ME update earlier this week. Hopefully, this can be sorted out.
     
  15. HYUK88

    HYUK88 New Member

    ME Update -> EC Update -> Bios Update(Failed).
     
  16. Feromoon

    Feromoon New Member

    Same problem with BIOS update.
    After first attemped i've unarchived *.exe to get error log from flasher.
    Got this:
    So it's definitely EC problem. Hope Razer will fix this soon, whanna try new bios =)
     
  17. crypticc

    crypticc New Member

    The ME pdf says to update bios first
     
  18. HYUK88

    HYUK88 New Member

    ME update posted 10 April , Bios update posted 12 April . *now they posted new ME upate 16 April
     
    Last edited: Apr 15, 2019
  19. shayanhe

    shayanhe New Member

    I also have the same issue on the 2019 Razer Blade 15 that I bought today.

    I also have a question about the trackpad. Is the entire trackpad supposed to be a click pad? My trackpad does not "click" on the upper 1/3 portion.
     
  20. HYUK88

    HYUK88 New Member

    all portions works for me
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >