USB Camera Glitching

Discussion in 'Razer Support' started by Starpool13, Sep 19, 2020.

Thread Status:
Not open for further replies.
  1. Starpool13

    Starpool13 New Member

    I have the Razer Blade 15” Advanced (2018). My USB camera has been acting funky recently, not sure why. When I use it, whether on discord or the camera app itself, it begins to flash green, cutting out my camera feed sometimes, having grey bars come across the screen, and often resizing it. I have no idea what to do. I went into the windows device manager, checked for updates, nothing. I've tried everything, and I guess I ran out of my warranty because my serial number does not have one according to the support fourm.
     
  2. mskhmelik

    mskhmelik New Member

    I have the same issue with my webcam and it got worse - now my camera feed is all in grey stripes and shaky...

    Help!....
     

    Attached Files:

  3. Starpool13

    Starpool13 New Member

    I appreciate the reply, I really wish someone could help us. How do you even do remote classes or anything with this camera problem?
     
  4. mskhmelik

    mskhmelik New Member

    Now it just stopped working. Microsoft Teams doesn't even detect camera now: it says there was a problem with a device.

    I tried to update the driver, killed the device all together and reinstalled and still nothing happens. :slightly_sad:

    Help!
     
  5. mskhmelik

    mskhmelik New Member

    Solved the problem after installing the latest updates from Microsoft through Windows update. Don't know what that was....
     
  6. freshletters

    freshletters New Member

    It seems that the Updates don't even work for me. I'll try again. But this is happening to me too!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >