Viper dock constantly disconnecting / won't work with usb dongle

Discussion in 'Razer Support' started by TonySinatra, May 5, 2022.

Tags:
Thread Status:
Not open for further replies.
  1. TonySinatra

    TonySinatra New Member

    Hello, the dock of my Viper mouse has randomly and constantly started to disconnect on Windows 11 since the past couple of months, with a message popping up saying "USB device not recognized".
    This stops happening if I plug the mouse usb dongle receiver into it, but if I do that the mouse stops working.

    I've tried to reinstall Firmware and remove then reinstall Synapse, and have tried every USB port on my machine with no effect. Thank you
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Please try connecting it to another computer with or without Razer Synapse installed. You may also try installing the Intel Driver and Support Assistant and check for the latest driver suggestions. Otherwise, the dock has a possible hardware issue and needs replacement. If you purchase it from a local store, please contact the store and request an exchange or send me a PM if it was bought from the Razer Store. I'll be locking this thread now. Feel free to visit our self-help options should you have other questions or concerns.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >