Why is Synapse so broken?

Discussion in 'Razer Synapse' started by Jayxe, Sep 24, 2022.

  1. Jayxe

    Jayxe Member

    Synapse is, without a doubt, the most embarrassing, unfinished, buggy piece of software I have ever had the misfortune of having to deal with. Why is it always - ALWAYS - so buggy?

    All I want is for the software to do what it tells me it's going to do. But that rarely happens. Macros don't record properly. Lighting effects don't save. Profiles don't switch. PROFILES DON'T SWITCH. This is the most incredibly annoying thing. I have a profile that I made for a game to spam quick attack (middle mouse button). and when I leave the game, it does not switch my profile back to default. So now when I middle click a web page to scroll, it just spams middle click until I manually change the profile back to default. There are so very many things wrong with all version of Synapse, and I plan to eventually write them down as I run into them. But it's getting harder and harder to recommend friends, or even continue to be interested myself, to Razer.

    I would be so embarrassed to have released not 1, not 2, but THREE incomplete versions of software for all the peripherals made from this company. I am a big fan of the aesthetics and ergonomics of a lot of Razer's stuff, but I 200% loathe the fact that this incredibly sub-par software is required to configure them, and doesn't even do it right.
     
    xFPDx, JulianKapa, pancholr and 5 others like this.
  2. Yunox

    Yunox Active Member

    I 100% agree.
    I updated my Synapse to the latest version and my Basilisk Ultimate just stopped working via wireless.
    I now have to to use my Basilisk Ultimate wired and it annoys me so much. Razer Support knows about the problem and I am not the only one with this problem but I have to wait for a bugfix I guess.
    I even bought a brand new Basilisk Ultimate just to be sure that this is a Software and not a hardware bug. I also double checked with different Laptops and PCs but its all the same.

    I really wish that Razer would fix their Software Problem.

    I love Razer Products... but the software makes it hard to recommend any of their peripherals.
     
    xFPDx, JulianKapa, pancholr and 2 others like this.
  3. yeah ive been fighting with synapse for days now, its always something.
    wont open on boot
    wont populate game list to link to profiles
    and NOW my blackwidow elite media knob wont work as long as synapse is running. hmmmmmmm.

    lets be real razer is just going to keep pushing this crap out for 13 yos in the suburbs with their parents credit cards.
    im putting all this crap on ebay and going corsair or logi, this is ridiculous.
    their support is always reinstall, if that doesnt fix it sign your life away with their extremely invasive logs, which will not lead to a solution.

    this is crap, but they dont care they already have my money. such trash.
     
    pancholr likes this.
  4. Itsmepancakess

    Itsmepancakess New Member

    i totally agree
    personally i just cant start synapse i tried all possible techniques but nothing works razer steals our money
     
    wexusis likes this.
  5. FiszPL

    FiszPL Well-Known Member VANGUARD

    Typically it's some runtime missing like .net 4.8 or Visual C++.
    Sometimes uninstalling Visual C++ helps.

    Also I'd recommend doing a clean Synapse install:
    1. Uninstall Synapse
    2. Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
    3. Then restart your PC
    4. After reboot install Synapse again (as administrator).
     
  6. xLegion93x

    xLegion93x New Member

    Just got Kraken headset, Viper ultimate and Huntsman mini USB devices where Viper is wireless. On The headset i've spatial audio purchased. Everything Works fine AFTER closing Synapse. Now this is clean install after Windows 10 Pro updates and chipset etc drivers.

    Symptoms:
    Random mouse disconnects 3-5 secs of duration.
    Random audio output device resets
    No input from keyboard

    Remedies:
    Re-install everything
    Firmwares up-to-date
    Different USB ports

    So im out of ideas. I just went to get all razer tech including itx case and now im having all these equipment as dead weight on My desk.
     
    KostasXD1234 likes this.
  7. Yunox

    Yunox Active Member

    Yeah, I just installed the new update that just released. Now my Devices show up in the small windows when I click on the synapse Icon in my Task Bar but when I open Synapse and go to the "Devices" Tab nothing shows up. My Devices work (my basilisk ultimate still only works wired tho) but I cant change any settings. It just keeps getting worse.
    Razer Software really is a nightmare. I stopped recommending Razer products because of their shit software and also shit responses when adressing MAJOR bugs.
     
    xFPDx likes this.
  8. Ali-Danish

    Ali-Danish New Member

    100% agree, synapse never detects my razer kraken, I have tried almost everything and it still doesn't work, it's just so annoying
     
  9. Florek81

    Florek81 New Member

    Yeah, this software works like ....!
    I updated to the latest version and now I can't set anything. After starting Synapse and try to set my Ornata, Basilisk and my Pad to a different RGB-Setting the Program freeze and nothing happens.
    Problem though is, that I turn off RGB when I'm watching a movie on my PC and now I can't set it to my normal RGB Setting which is very annoying.
     
  10. SweaNisseGaming

    SweaNisseGaming New Member

    this is for Razer Synapse 3 version RazerSynapseInstaller_V1.9.1.344.exe
    even after the last update which is done on November 8, 2022
    Razer Synapse version is named 3.7.1103.110716

    install file is named RazerSynapseInstaller_V1.9.1.344.exe
    the update version is Razer Synapse version is named 3.7.1103.110716

    (but this problem still remains)
    another problem has now come up

    get exactly the same message
    "dial tcp 10.0.1.166:6380: connect: connection refused"
    managed to get back into my account using the forgotten password feature
    thus enters your own Razer account, but you cannot revoke the previous session and reconnect with a new session to your own Google account
    when I still try, you get a new notification
    access token is invalid




    have also tried to save as local or in the cloud the same problem no matter what I choose anyway



    (Export a profile)

    thus only trying to save the profile, i.e. exporting data from my own profile to a file that the Razer Synapse 3 can understand and interpret already there it stops as one's own settings are never saved at all


    (Import a profile)

    thus only trying to save the profile, i.e. Importing data from my own profile into a file that Razer Synapse 3 can understand and interpret already there it stops as one's own settings are never saved at all



    strange behavior when export your profile
    when Hypershift should also be enabled

    strange behavior when import your profile
    (note that Hypershift should also be enabled)


    this setting is easy to test out


    enable Hypershift



    Left Click
    Speed (press/20 sec)
    enable Turbo

    Right Click
    Speed (press/20 sec)
    enable Turbo

    setup the profile as you want the profile


    then test to export and import as see if this setting got saved or not
     
    Last edited: Nov 13, 2022
  11. Jayxe

    Jayxe Member

    What the fuck is this Razer? I only ever created 3 profiles. 3090MonsterDefault, Warframe, and Satisfactory. Why the hell are 3 more defaults made? Why won't the profile change from Warframe to Default when I close Warframe? And now, why won't any macros work under Hypershift? It claims I need synapse to run. IT'S RUNNING! Seriously, Razer, fire -EVERY- person in your software department and hire people who know what they are doing. This is absolutely BONKERS that the program is so incredibly broken and mishandled. Min Lian Tan, if you're reading this, I feel so embarrassed for you. This type of quality in the software is just so poor. I would never stamp my name on such low quality material.
     

    Attached Files:

    xFPDx and Yunox like this.
  12. Yunox

    Yunox Active Member

    Amen.
     
  13. fastIcterineup573

    fastIcterineup573 New Member

    Huntsman Elite Kept spamming keys now only spams Y but problem disappears with Synax off
     
    FiszPL likes this.
  14. lowendth3ory

    lowendth3ory New Member

    After dealing with crazy firmware problems with my BlackWidow Mini, now my fucking lighting doesn't work when Synapse is on. What the fuck is this shit? This company hopelessly sucks. Will never buy anything from them again. These firmware and software bugs are just embarrassing.
     
    xFPDx likes this.
  15. xFPDx

    xFPDx New Member

    My gear is usually detected. However, my problem is that Synapse only remains functional for 3-5 minutes while in Studio. I know saving often is a good idea, but with this P.O.S. software, I have to save after every single design change. Even the smallest change. I never know when Synapse is going to crash. I've been down the "Uninstall re-install" road a few times already. I've watched the videos, read the chatter, done this, that and the other thing and it just comes down to this: The Razer software engineers should all be fired! Like Yesterday!
     
  16. AndreAzevedo

    AndreAzevedo Member

    stop demanding mass layoffs, you don't know people who develop synapse 3 about their mistakes, failures and successes. but what you should expect is that they take responsibility for what they do in the name of razer.
     
  17. xFPDx

    xFPDx New Member

    I know if I had this many issues that were so blatant, I would have been fired when I was programming. At the very least, figure out who is responsible, and show them the door. I don't care how many there are.
     
  18. AndreAzevedo

    AndreAzevedo Member

    don't be surprised we're still on the turing line we'll still see a lot of broken bytes
     
  19. xFPDx

    xFPDx New Member

    Try Lovelace. A much better test of AI. There are probably better ones too. But I digress.
     
  20. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    I just rebuilt my Windows 10 OS from scratch.
    The best fix is to rebuild~~~
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >