Windows AUDIODG.EXE crash due to THXSYSVAD2APO.dll

Discussion in 'Audio' started by everDarkBlueCORAL706, Feb 16, 2021.

  1. Hi,

    I recently bought the Blackshark v2 headset and enabled THX surround sound. I'm seeing in the Windows Event Viewer that periodically, the Windows AudioDG.exe process will crash with event details:
    Faulting application name: AUDIODG.EXE, version: 10.0.19041.804, time stamp: 0x985b4154
    Faulting module name: THXSYSVAD2APO.dll, version: 1.2.6.0, time stamp: 0x5ed576b1
    Exception code: 0xc0000005
    Fault offset: 0x0000000000002d7b
    Faulting process id: 0x2614
    Faulting application start time: 0x01d7049d86d6f64e
    Faulting application path: C:\Windows\system32\AUDIODG.EXE
    Faulting module path: C:\Windows\System32\THXSYSVAD2APO.dll
    Report Id: a421a213-1ac6-4684-90e1-10fae8910e99
    Faulting package full name:
    Faulting package-relative application ID: ​

    Is there an updated THX driver that addresses this problem?
    Thanks.
     
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    I'd try reinstalling THX driver, or try to repair system by running cmd as an administrator then typing: sfc /scannow
    You can also try to update your W10 to 20H2 version. Seen many times, that some function/app was not working until windows was updated to higher version.
     
    pancholr likes this.
  3. Thanks for the suggestion. I ran it just now and the resulting log file doesn't seem to indicate there was an issue with either the audiodg.exe or the thxsysvad2apo.dll files. I'll check my Event Viewer over the next couple of days to see if the problem goes away or not.

    BTW, my system is already running 20H2 even before buying the Blackshark v2.
     
    pancholr and FiszPL like this.
  4. xmudslingerx

    xmudslingerx New Member

    Was there ever a confirmed resolution on this? I am having the identical problem with a new Razer Blackshark V2 Pro. It is crashing my enter system over and over:

    Faulting application name: AUDIODG.EXE, version: 10.0.19041.804, time stamp: 0x985b4154
    Faulting module name: THXSYSVAD2APO.dll, version: 1.2.6.0, time stamp: 0x5ed576b1
    Exception code: 0xc0000005
    Fault offset: 0x0000000000002d7b
    Faulting process id: 0x3260
    Faulting application start time: 0x01d70f83a42be140
    Faulting application path: C:\WINDOWS\system32\AUDIODG.EXE
    Faulting module path: C:\WINDOWS\System32\THXSYSVAD2APO.dll
    Report Id: dee7adfd-6e9c-4bef-ac98-2bbaa7008bb6
    Faulting package full name:
    Faulting package-relative application ID:

    EventData
    AUDIODG.EXE
    10.0.19041.804
    985b4154
    THXSYSVAD2APO.dll
    1.2.6.0
    5ed576b1
    c0000005
    0000000000002d7b
    3260
    01d70f83a42be140
    C:\WINDOWS\system32\AUDIODG.EXE
    C:\WINDOWS\System32\THXSYSVAD2APO.dll
    dee7adfd-6e9c-4bef-ac98-2bbaa7008bb6


     
    Flexo_3370318 likes this.
  5. FiszPL

    FiszPL Well-Known Member VANGUARD

  6. Flexo_3370318

    Flexo_3370318 New Member

    The issue is with the THXSYSVAD2APO.dll that is part of the Virtual THX Spatial Audio device itself and Razer needs to update it.

    I have this exact same error if I leave the THX Spatial Audio set as the Default Sound Device with the Razer BlackShark V2 Pro set as the Default Communication Device which is the recommended default from the Synapse 3 software. If I set the default device in Sound Properties to JUST the BlackShark V2 Pro only this error does not occur whatsoever.

    I have updated the BlackShark V2 Pro to the latest firmware, I have removed and re-installed the Synapse 3 Software, I've changed USB ports that the wireless receiver is plugged into and I even went as far as completely wiping the entire OS from the system and reinstalling Windows from scratch from a Windows Installation USB Drive and the error still persists when the THX Spatial Audio is set as the default device.

    My system is fully up to date with all the latest available drivers and bios, and my full specs are below.

    Case - Cooler Master H500M
    Cooler - Noctua NH-D15 Chromax
    CPU- AMD Ryzen 9 5950X
    Motherboard - Gigabyte X570 Aorus Xtreme rev 1.0 Bios version F33c
    Memory - G.SKILL Trident Z Neo 32GB (4 x 8GB) DDR4 3600CL14 (F4-3600C14Q-32GTZNB)
    GPU - PowerColor Red Devil RX 6900 XT
    Drive 1 (OS) - Gigabyte AORUS NVMe Gen4 SSD 500GB M.2
    Drive 2 - Gigabyte AORUS NVMe Gen4 SSD 2TB M.2
    Drive 3 - Samsung 860 EVO 2TB SSD
    Power Supply - Seasonic PRIME 1000 Titanium SSR-1000TR 1000W 80+ Titanium
    Keyboard - Razer Huntsman TE
    Mouse / Mousepad - Razer Mamba HyperFlux
    Webcam - Razer Kiyo
    Headphone Stand - Razer Base Station V2 Chroma Headset Stand
    Razer BlackShark V2 Pro
    Razer Chroma Addressable RGB Controller
    OS - Window 10 Pro Version: 20H2 Build: 19042.804
     
    nikkiepacheco likes this.
  7. xmudslingerx

    xmudslingerx New Member

    I concur with @Flexo_3370318

    I also have updated the BlackShark V2 Pro to the latest firmware, removed and re-installed the Synapse 3 Software, and changed USB ports that the wireless receiver is plugged into. Error persists when the THX Spatial Audio is set as the default device. (I have not reinstalled the OS).

    "The issue is with the THXSYSVAD2APO.dll that is part of the Virtual THX Spatial Audio device itself and Razer needs to update it."
     
  8. Flexo_3370318

    Flexo_3370318 New Member

    I tried opening a ticket about this issue too, but Razer's support staff was useless. It would be nice to get some kind of answer regarding this issue. Even a we're looking into it would be nice.
     
  9. Flexo_3370318

    Flexo_3370318 New Member

    Despite the update to Synapse 3 the other day this issue is still present when the THX Spatial Audio is selected.
     
  10. Flexo_3370318

    Flexo_3370318 New Member

    Hello anyone from Razer!? This is still an issue despite the recent updates to Synapse, it's been an issue since January / February and it's now April. An acknowledgement of the issue would at least be nice, a fix would be even better.
     
  11. SaiBorkX

    SaiBorkX New Member

    Just want to say I have the exact same issue. No issues when Synapse isn't installed, but as soon as it's installed and updated to support the BlackShark V2 Pro it starts giving these errors. Windows 10, 20H2 with latest updates and latest Synapse with latest firmware on the headset.
     
  12. cptprice0519

    cptprice0519 New Member

    Same error, same issue as well. Sadly, even when i change it from THX to some other playback device the error still persists. Everything up to date. It's beyond me how Razer thinks this will not affect their reputation. Every game is crashing due to this for me.
     
  13. Flexo_3370318

    Flexo_3370318 New Member

    Another Synapse update and issue still persists all because Razer refuses to fix / update the DLL file causing the problem.
     
    nikkiepacheco likes this.
  14. nikkiepacheco

    nikkiepacheco New Member

    Great to hear people are experiencing the same problem, of course it is not good news. I guess I'll go ahead and follow your advice first and see if it works before I reinstall my OS. I've tried the other tricks you've mentioned @Flexo_3370318.
     
  15. Flexo_3370318

    Flexo_3370318 New Member

    Yet another Synapse Update that has done nothing to resolve this issue because Razer refuses to look at the actual .DLL file that is in the error which is causing the AudioDG.exe to crash in the first place and fix or update it.
     
  16. bestRoseBonbon965

    bestRoseBonbon965 New Member

    I just want to add my name to the list of people with this same problem. Tried updating firmware, clean reinstall of windows, clean install of synapse, running it as admin, sfc, etc. Synapse will open for a couple of seconds, but will then simply crash without posting an error (its logged in event viewer). I have even tried not installing the blackshark v2 and only install my Basilisk Ultimate mouse in the hopes that i can set a macro for the paddle button so that i can actually use the damned thing in a game.

    Total waste of money. I can't believe there isn't a way to map the mouse buttons via a third party app. NO I CANT RUN SYNAPSE LONG ENOUGH TO SAVE OR LOAD A PROFILE.

    Oh. MSI X570 Gaming Edge Wifi with latest firmware....for a while i though nahimic had something to do with the problem, but again...clean install, onboard audio disabled in bios prior to windows clean install.
     
  17. Happening to me as well. It's clearly a bug in this library
    I purchased Dolby Atmos Headphone a long while back, I've had to disable THX and revert to that for some decent form of simulated surround. If they fixed it, or worked with MS to fix it if it's some other issue in windows spatial plugin support, I'd switch back in a heartbeat. I agree with one of the comments above that an ACK of the issue and a "we're looking into it" would be cool. I would imagine they know it's happening though.
     
  18. Flexo_3370318

    Flexo_3370318 New Member

    They do know about it for sure and just don't want to look into it, or admit is an issue with the .dll file. I have gone back and forth with a Razer Level II Technical Support Representative over this issue for several weeks and they are basically telling me the Dev Team is passing it off as being caused by some external factors. Below is one of the last responses I received back from Support.

    "Good day!

    Thank you for patiently waiting for our email and we apologize for the delay.

    With the information that you have provided, and after carefully attempting to reproduce your issue, our Development Team identified that the behavior of your software is caused by external factors outside of our team’s means. This means that there may be third party software installed or corrupted files on the operating system that is affecting your Razer Software to behave this way.

    Below are some of our steps that you may want to perform that might help you rectify the issue. Please note that pursuing any of the below steps is totally up to you as Razer will not be liable for any Data Loss, Data Corruption, or any effects that would result by performing any of the steps below. Also, do note that these steps are not guaranteed a fix to the issue, it is recommended that you should keep your Razer Software up to date.

    1. Uninstall/Reinstall Synapse (Recommended)
    2. Install/Uninstall any latest Mac OS or Windows Update
    3. System Maintenance
    4. Reset/Reinstall/Repair Operating System. (Only recommended for Razer Systems; Razer Blade etc.)

    Thank you for cooperating with us and please feel free to keep us posted."

    This is despite me explaining multiple times that the issue is reproducible on a fresh windows install with nothing but Windows and Synapse 3. I've even pointed them to this thread to show it is not an issue isolated to me alone and that there are at least 8 people in this thread alone that have noted this issue and the only commonality among us is we have a Razer BlackShark v2 Pro. Not to mention the 1,172 or so people that have viewed this thread that likely have this issue as well, but haven't commented on it.

    I have pretty much given up at this point and just set the default sound device to the Razer BlackShark V2 Pro device entry to avoid the error and don't use the THX Spatial Audio device at all.
     
  19. FWIW Synapse just updated today, but this library is still the same file from May 2020 v1.2.6.0 .. guess I'm still using Atmos Headphone
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >