Windows Driver Foundation 100% CPU usage

Discussion in 'Razer Synapse' started by Ghadaffi, Feb 25, 2019.

Thread Status:
Not open for further replies.
  1. Ghadaffi

    Ghadaffi New Member

    Hi! so straight to the point, my CPU usage reach 99%-100% and when I open task manager, "Windows Driver Foundation" sitting on top of the list. This happen everytime I use Razer Synapse software. I'm using Electra V2 USB Headset.

    PS : I've try to plug it on 2.0 & 3.0. I've try to plug it on my MOBO, and even my cpu casing port. Yes I've done uninstall the software and and the devices as well. Like, completly uninstall all stuff related to razer on my pc and it doesn't change anything. I've been looking around the internet for solution for so long but didnt found "tips" that really worked out. I noticed I'm not the only one who encounter this problem. Any help?
     
    adamr01 likes this.
  2. xInSaNeKiLLs

    xInSaNeKiLLs New Member

    Don't bother dude. I got the same headset and same problem. This has been here since november/december. They are never gonna fix this. What a shitty company this is. They don't even bother to even reply.
     
    adamr01 likes this.
  3. rajab0v

    rajab0v New Member

    I Might have a temporary solution that will let you get the benefits of razer synapse 2 without it being open and it works 100% with me,

    I have Razer Electra V2 USB and I was suffering from the high CPU usage from razer synapse 2 and windows driver foundation whenever I open Synapse 2, and it disappears when I unplug it from my computer or force end task for the razer synapse application

    All what you have to do is:

    1. Open Razer Synapse 2.
    2. Do whatever settings you want to do with it for your headset and your microphone.
    3. Under the headset picture press on "sync now" link.
    4. Put Razer Synapse 2 on offline mode ( this is the most important step).
    5. Go to task manager, find Razer synapse (32bit), select it and press end task.


    BoOoOom:big_grin_::big_grin_::big_grin_:, it works! you still can get the benefits now from Synapse without it being open now, and also the CPU Usage now is 0%.

    I've made sure that this works by playing with the equalizer and make the sound feels odd then i've done the steps above and it works.

    Please try this and let me know the results, This should work until Razer Co. makes a solution for their shitty software.

    Salute!:wink_:
     
    bizAzureMistlab572 and adamr01 like this.
  4. PCGamer231231

    PCGamer231231 New Member

    I have this too.. everyone seem to have this :/
     
    adamr01 likes this.
  5. Unfortunately razer support seems to liek to play ping pong with my case and not send a single working solution my way, if i dont get something that helps me soon im going to throw this worthless headset in the trash and actually downgrade.
     
  6. Weaponhead

    Weaponhead New Member

    I also used this Razer Synapse 2 temporary solution, but instead for lagging mouse issues (Razer Taipan - Evil Geniuses edition)
    The syncing and then going offline mode was definitely the key.
    It seemed as though when Razer Synapse 2 was active in online mode, it didn't know which mouse presets to use while it was continuously syncing.
    I've had no Mouse issues since using this method.

    Hope you have the same luck
     
  7. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    This issue is fixed with today's update for Synapse 2.
     
    PCGamer231231 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >