Wireless Razer Mamba 16000DPI doesn't show on Synapse 2.0

Discussion in 'Razer Support' started by DiogoSuicida, Apr 14, 2021.

Thread Status:
Not open for further replies.
  1. DiogoSuicida

    DiogoSuicida New Member

    Hi,

    I have a wireless Razer Mamba 16000DPI (the one with the dock and that came in a tin box) and for some reason it stopped appearing on synapse 2.0 and on synapse 3.0 it shows that I have a compatible device with 2.0 (the razer mamba).
    I tried clean install for both synapses, tried removing synapse 3 and clean install synapse 2.0, tried doing the previous thing and remove all devices from device manager and reinstall them. I also tried to find firmware online to update mine but I couldn't find it. I oppened tried online chat with razzer support, but once they found out that my device was not under warranty they removed me from the chat and I couldn't ask anything else.

    I don't know what else to do since it is a really expensive mouse and I like its design but I can't change any of its configurations (dpi, color etc) and can't seem to get any help.

    Thanks,
    Diogo Pedrosa
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >