Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

World of Warcraft still not working?

Discussion in 'Razer Cortex' started by PhrostByt, Jun 5, 2019.

?

Does world of warcraft give you razer points?

  1. Yes

    7 vote(s)
    41.2%
  2. No

    10 vote(s)
    58.8%
Thread Status:
Not open for further replies.
  1. Sliproach

    Sliproach Active Member

    Any one having this issue with LoL when i launch it from the Rewards/ supported games tab it for some reason starts to install a new copy on LoL on my pc, but the copy i have works fine if launched from the my library tab.
     
  2. xCryptik

    xCryptik Well-Known Member VANGUARD

    Hi Sliproach,
    May I know which region did you installed for the League of Legends?
    I tested myself for NA and SEA region. It works fine either lauching from Rewards or My Library.
     
  3. Sliproach

    Sliproach Active Member

    I play on EU West i think it's fixed now was something to do with a update on LoL which instead of opening the out of date client and letting me update when i try to run from rewards it tried to install a new up to date client but now I've updated the client manually it launches the game no problem was just a strange occurrence. but thanks for testing it out.
     
    xCryptik likes this.
  4. xCryptik

    xCryptik Well-Known Member VANGUARD

    Since you launched LoL from Cortex, they usually directly runs the LeagueofLegends.exe which differs from the original LeagueClient.exe which supposed to run to check for files that's already in your system.
    Anyways, I'm so glad it works fine for you now.
     
    Sliproach likes this.
  5. AlphaTay

    AlphaTay Member

    Razer Cortex Mobile doesn't seem to be able to Track Today, still having the Full Earned Razer Silver of Yesterday, unable to Earn any Razer Silver Today.

    UPDATE: doesn't Track for Friday, working for Saturday, doesn't Track for Sunday again.

    UPDATE: doesn't Track for Monday too.

    UPDATE: working for Tuesday.

    UPDATE: doesn't Track for Wednesday.

    i tried to do the Tracking mission as usual when there's Tracking issue, but didn't receive Razer Silver afterward too.
     
    Last edited: Nov 5, 2019
    Kenserky likes this.
  6. ckdo1974

    ckdo1974 New Member

    As usual: same here. SNAFU.
     
  7. 0V3R_K1LL

    0V3R_K1LL Well-Known Member VANGUARD

    Good to know someone is keeping track of this. I thought this was just my issue but now I see everyone has it.
     
  8. Sacius

    Sacius Well-Known Member

    Yea, it was working yesterday, but doesnt again today.
     
  9. ckdo1974

    ckdo1974 New Member

    And NOW it starts to get interesting: For me it didn't track on Tuesday either. In addition, the only game to carry the "25" tag in Cortex currently is the paid one, Rayman Jungle Run. The tag is missing on the three free games.

    Edit: After the P2P lineup changed, it's tracking again.
     
    Last edited: Nov 6, 2019
  10. Kenserky

    Kenserky Well-Known Member

    I got the felling that Cortex mobile works only one days on two since tuesday last week.
    Kind of strange, or is it a new update that i didn't see coming ?
     
  11. ckdo1974

    ckdo1974 New Member

    The only thing that's certain is that it doesn't work... again.
     
    Kenserky likes this.
  12. Kenserky

    Kenserky Well-Known Member

    Seems to be fixed today, let's hope it'll stay like this.
     
  13. Sliproach

    Sliproach Active Member

    Looks like there might be a reward issues today, tracking the games launching but no bubble upon exiting a game to say what had been earnt.
     
    Kenserky likes this.
  14. Kenserky

    Kenserky Well-Known Member

    Same here neither Rocket League or Minecraft seems to be working.
    Just after Cortex Mobile has been fixed, talk about a curse....
     
    Sliproach likes this.
  15. Sliproach

    Sliproach Active Member

    Hoping it'll come through tomorrow, as cortex is tracking them as being the last played games, normally just turns out to be lag/ a glitch in the system.

    Update:

    Can confirm I received my 100 silver from yesterday this morning.
     
    Last edited: Nov 25, 2019
    Kenserky likes this.
  16. Hermanator

    Hermanator Well-Known Member

    Reboot PC first before even thinking about reinstalling.
     
  17. PhrostByt

    PhrostByt Active Member

    anyone know what version of Minecraft is supposed to give zsilver this week? I tried both the java and windows 10 versions and neither seem to be working properly
     
    Hermanator likes this.
  18. Sliproach

    Sliproach Active Member

    I'm running the Java version and it seems to be rewarding silver per usual atm. 'touch wood'
     
    Hermanator and Kenserky like this.
  19. PhrostByt

    PhrostByt Active Member

    works for me after updating launcher to latest version, thanks!
     
    Hermanator, Kenserky and Sliproach like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >