Razer Blackwidow V3 Mini not working | Razer Insider

Razer Blackwidow V3 Mini not working

  • 13 December 2022
  • 7 replies

i recently installed signal and ive noticed that all my devices work except for the blackwidow mini. If anyone could let me know why im facing this problem and how i could fix it that'd be great.

7 Replies

Good Morning,

Me and my son make use of distinct keyboards Blackwidow v3 Mini Hyperspeed

After several days on vacations, when powered my keyboard to get back to work, I noticed that several keys no longer respond.

I took my son's keyboard and connected to my laptop to make sure it was not something in the laptop.

My son's keyboard is working just fine and perfectly in my laptop.

So after research, I decided to apply a hard reset on my keyboard, using this procedure:



Then the situation got even worse, the keyboard went into that mode where the key pressed, trigger a wave of colors around the keyboard, so in  that way, I can see that the key is being responsive, but in the  laptop that or any to be more precise, any other key pressed, have no action at all.

For instance if I open a text editor and type in a text, I can see in the keyboard, that every key typed, can trigger that colors wave, but in  the text editor, there is no text at all typed.


Actions already tried:

1 - Hard reset

2 - Connect directly to another USB port via cable provided with the keyboard (tried two distinct ports)

3 - Connect directly to another USB port using the 2.4GHz dongle (tried two distinct ports)


Keyboard serial: IO2131F61105735

Model number: RZ03-03891900

Razer Synapse Version: 3.8.1231.120811  


Please help


Updated Razer Synapse to version

Firmware Version in use: (Noticed that my son's keyboard is using firmware

  • Testing again, noticed that several keys like the “1” only trigger the color wave in the keyboard, after being pressed several times
  • Before leave on vacations, I noticed that out of the blue, only that key “1” would lit in purple and I had to power cycle the keyboard to fix that
  • Before stop completely, also noticed that several keys get typed in duplicity, like you strike “n” once and it gets typed twice.

Problem remains the same on my keyboard which is completely unresponsive to the laptop and with several keys not working at first strike.

Please help

Updated Firmware in the 2.4GHz dongle and also in the keyboard, to the version

Problem persist… Keyboard still unresponsive to the laptop


It's unfortunate to hear that your Blackwidow Mini keyboard is not working with Signal on your devices. There could be several reasons why this is happening.

Firstly, ensure that your keyboard is connected and functioning properly. You can try disconnecting and reconnecting the keyboard, or testing it on another device to ensure that it is not a hardware issue.

If the keyboard is functioning properly, the issue may be with the Signal app itself or with your device settings. You can try reinstalling Signal, or checking if there are any updates available for your device's operating system or drivers.

To troubleshoot the issue, you may want to try the following steps:

  • Check that the Blackwidow Mini is properly connected and powered on
  • Ensure that you have the latest version of Signal installed on your device
  • Try restarting both your device and the Blackwidow Mini
  • Try connecting the Blackwidow Mini to a different device to see if the issue persists
  • Check for any error messages or logs in Signal that may provide more information about the issue

If none of these steps work, you may want to consider reaching out to Signal's support team or the manufacturer of the Blackwidow Mini for further assistance. They may be able to provide more specific guidance on how to troubleshoot the issue

It's possible that the current drivers are not compatible with Signal. Also, try checking the Signal settings on your Blackwidow Mini to make sure that it is allowed to access the microphone and speaker. If the issue persists, you may want to contact the Signal support team or the keyboard manufacturer for further assistance. Hope this helps!

Userlevel 7
Badge +1
So you're trying via 2.4 Hyperspeed mode? Try to put dongle directly into USB port on your motherboard avoiding any USB hubs etc (preferred USB 3.0 and above).

Did you've tested Bluetooth mode or wireless mode to check if it'll work?