Razer ripsaw | Razer Insider

Razer ripsaw

  • 21 January 2020
  • 7 replies
  • 4 views

Hi everyone I need help with the capture card, I don't understand why the red color comes out. This is connected to a playstation 4

https://ibb.co/7RmDFTq


Thank you for reply and help!

This topic has been closed for comments

7 Replies

Userlevel 7
Comtar
I am having a similar issue and have a Razer Raptor monitor, anything I can do? I have a thread about my own issues that has gotten no reply.

There's a firmware update that targets to fix discolored videos when paired with some monitors. PM me the serial number of your Ripsaw HD so I can give you the updater. That said, I'll have to lock this thread to prevent hijacking.
I am having a similar issue and have a Razer Raptor monitor, anything I can do? I have a thread about my own issues that has gotten no reply.
Userlevel 7
@DougBadass

Thanks for updating the thread, and for sharing the fix you found. I honestly didn't even think that freesync can cause such oddities. See you around, bud!
OK I finally found the solution to this problem.
I have a 144 hz freesync monitor, and freesync was ON, when I turned off freesync and then connected again the Ripsaw HD colors were ok as should be.
A firmware enabling feeesync support is necessary.
Userlevel 7
DougBadass
I have the same problem with my Nintendo Switch. I have re installed synapse 3, replaced cables, re installed obs, but the problem persists.
Support razer we need a SERIOUS SOLUTION please.


Was this right after the initial set up? I have not had any luck trying to replicate this from my end. I'd appreciate it if you can send a short clip showing how your streaming rig is interconnected.
I have the same problem with my Nintendo Switch. I have re installed synapse 3, replaced cables, re installed obs, but the problem persists.
Support razer we need a SERIOUS SOLUTION please.

Userlevel 7
Reseat if not replace the cables. I'd appreciate it if you can put up a short clip of how everything is connected.