System not receiving "Adequate Power" | Razer Insider
Question

System not receiving "Adequate Power"



Show first post

160 Replies

Iv had this issue for years. This was already my 2nd replacement, then this happened a few months in (2022). I had given up as no one was talking about this issue, now a bunch of people are. I was so excited for this laptop and its been a nightmare for years in so man ways. Razer gave me the run around.

I ordered an generic 230w charger off amazon and it didn't fix the issue. Some said buying a 280w might fix it, but whats that… 350 canadian? wild. Razer.. what is going on?

 

Userlevel 1

Another update came 20230731. Still didn’t fix my Blade 17 2022.
 

 

 

So after reading through all the messages I have from Razer support what appears to be happening is that the logic behind Synapse performance modes is checking the hardware and those of us that have “230W” power bricks are being handicapped. Since ALL the new Razer Blades come equipped with 280W & 330W power adapters the logic has those listed as the adapters required for the “Performance” modes.

 

Essentially this is what Apple did as planned obsolescence years ago with there iPhone battery's and lost a multi million dollar class action suit. As of now myself and a few others have sent this info to Linus Tech Tips & Gamers Nexus to do a story on this because it affects anyone who purchased a Razer Blade with a 230W power brick.

Userlevel 3

I got rid of all my razer files until a fix has been created.

same problem here

Our laptops just lost their balls. We can’t use the performance mode and now it’s like 200 bucks system with a very good screen. I really hope that the devs will fix their BIOS. The issue in BIOS, that’s why any software manipulations will not help. I do not recomment to roll back previouse BIOS. Things can go wrong and you can brick your machine. But if anybody managed to do so, please let us know the steps to do it safe. 

Just wanted to say Hi as Im having the same power problem with my 2021 Blade 14. I tried so many things to solve this issue - as you know, nothing helped yet. 

I checked with an other 230W adapter that didnt change anything. So Ill have a look at those bigger bricks. Ill keep you posted.

 

Cheers!

I have the same issue...

i have blade 15 advanced 2021 when i plug it in the chage they give me this mess “the system does not have enough power to enable high performance modes. please use the supplied power source to experience optimal performance” i don’t know and i don’t have the gaming mode 

 

Update I joined the Razer Synapse beta for the newer version of Synapse in development and while after install it says that the Razer Blade 18 is still in development for use with the beta. I am getting vastly better results when running a benchmark test than with ordinary synapse 3 installed.

 

If anyone wants to try it out and confirm if it’s better you can request access to the beta here:

 

https://insider.razer.com/groups/the-razer-synapse-beta-53

I fully reset my razer blade to factory settings and went straight to synapse to stop it from auto updating. Computer working just like the day I bought it. My razer keyboards and mouse also still work. Sucks to reset your whole device but hope it helps.

THis is a GREAT idea.  I will have to do this.

Userlevel 1

Thought I’d show a picture also to hurry this fix up. Felt cute might delete later 

Userlevel 1

Tried to report to razer support but they seem to want every little type of info out of me before they can help. Kinda sad since many people are having this issue 

Yeah this is insane. I called to inform them but the representative hung up on me in the middle of me explaining and the worst part was she was making it sound like there was static 

This issue is absolutely crazy.  I’ve been trying to resolve this for over a year now. I’ve purchased an extra power supply. I’ve reinstalled / factory reset.  I’ve been stuck with a $2500 laptop that cannot run software or games for over a year now.  I will 100% never be buying a Razer product again and telling everyone I know to avoid at all costs. 

Userlevel 1

Fix???

Userlevel 1

Let fix this issue by not buying razer products ever again and let the community why they should not, that’s what I’m doing,

I’d rather the issue get fixed so I can use what I paid for. 

Why are they not rolling back their update until they figure this out?  I shouldn’t have to send them tons of information.  Geesh my son works fixing code in the lab in AMD, this stuff happens, they don’t leave it out there broken.

 

I have a razor 15 base model and when I go to put my laptop into gaming mode, I am unable to because synapse is telling me that the laptop is receiving inadequate power which is stunting my performance. I have no every changed charging adapters and my laptop came with a 180W adapter. I also checked my battery life and it is at 96 percent, and have noticed zero swelling. I was wondering what I can do to fix this inorder to get the maximum performance out of my laptop.

Hi Insiders from this thread! The team wants to assist everyone who is still experiencing the error showing your unit can’t enable the high-performance mode. Please help us initiate a case to our Support Team by submitting it here: https://mysupport.razer.com/app/warranty-support. Otherwise, please send me a PM so I can create and forward the case number to our Support and Devs Team. I appreciate everyone’s cooperation.

same issue with my razor 15 base model, just summited a case 230630-000715  @Razer.Speedcr0ss 

Userlevel 7

I have a razor 15 base model and when I go to put my laptop into gaming mode, I am unable to because synapse is telling me that the laptop is receiving inadequate power which is stunting my performance. I have no every changed charging adapters and my laptop came with a 180W adapter. I also checked my battery life and it is at 96 percent, and have noticed zero swelling. I was wondering what I can do to fix this inorder to get the maximum performance out of my laptop.

 

Hi SemperParatus92 and everyone on this thread. Please help us kick-start an investigation by initiating a case here: https://mysupport.razer.com/app/warranty-support. If you have an existing ticket, please send it to me via PM so I can tap our Support Team. I appreciate your cooperation.

Userlevel 1

At this point all I can say is that I will not be purchasing another Razer device ever again. This was my 10th Razer branded laptop and the issues over the years have progressed exponentially with hardware and software failures. No with this one being a complete software / BIOS failure and a $3000+ PC that is essentially  a paperweight at this point I AM DONE. This is the type of failure that results in mass litigation & class action suits (Apple for example). Over a month with no fix, for a software update they released… F’ing REALLY?

 

 

Still having this issue 9 months later… Massive FPS loss in games...

 

Same thing here, synapse updated today and I started to get this message.  I read on Reddit a few people started getting the message after updating on other models several months ago “https://www.reddit.com/r/razer/comments/x7grag/error_the_system_is_not_receiving_adequate_power/”  So I’m uninstalling Synapse until I see a fix. Windows lets me put the system on high performance from Balanced the old way, without their software.  Seems to be a software issue.

Userlevel 3

I tried the same but sadly my system seemed to be running even slower while gaming without synapse 🥲.I’m on a razer blade 15 2020 base model 

Same issue on Razer blade 15 2020. I even bought a new power supply. Nothing changed. 

I tried the same but sadly my system seemed to be running even slower while gaming without synapse 🥲.I’m on a razer blade 15 2020 base model 

Did you use windows to change your power plan to high performance?  You can go in and change it and then customize it through windows Power plan options so it won’t turn off screens, USB keys, hard drives etc.  Make sure you are at least on the Windows High performance plan and then if you want you can customize every part of it by clicking advanced features.  If this doesn’t work for you then something else may be happening on your machine.  This should set it so full power goes to your hard drive, usbs etc.  Best done from the control panel, then type in Power to see the power plan options.  On some machines (like HP) they hijack the power plan settings also you need to click Create a power plan, take the High performance option, then rename it and customize.

After a lengthy back and forth with support I’ve been told that a fix will come in a future update of Synapse.

Reply