Leviathan V2 subwoofer not working | Razer Insider

Leviathan V2 subwoofer not working

  • 25 December 2022
  • 17 replies

Just got my Leviathan V2 with the subwoofer and got it plugged in and everything, but you can barely hear any bass coming from the subwoofer. I've seen online that the THX driver that automatically gets installed causes an issue with it work, so I uninstalled that, but nothing. Also saw the Synapse causes an issue with the subwoofer working also, so I uninstalled that, and it still doesn't work. I can put my ear up to it and I barely hear sound coming from it. Any thoughts?

17 Replies

To get my sub working again, Went into sound properties => playback => Select Razer Leviathan V.2 => Properties => Advanced Tab => Uncheck “Enable Audio Enhancements” => Apply Sub started working as soon as I hit Apply!

Cult of Razer 4 Life!

The way I was able to get it working was to disable and uninstall all the speakers through device manager after running the audio trouble shooter.and I didn’t reinstall synapse. Good luck 

Had the same issue. Simple fix, make sure center focus is OFF in synapse. I was playing a bass test song on you tube and when I toggled that off my desk vibrated and my case was shaking lol. Actually a pretty powerful sub.


To get my sub working again, Went into sound properties => playback => Select Razer Leviathan V.2 => Properties => Advanced Tab => Uncheck “Enable Audio Enhancements” => Apply Sub started working as soon as I hit Apply!

Cult of Razer 4 Life!

This guy right here is a wizz this is no joke the answer kudos to you brother


This is my first and only Razer device. I will never buy another one. It is only until now, I’ve been able to get this thing to work properly. 

Atomic_Cuddles, I am in the same situation as you with GG. Although, that had nothing to do with it. The entire problem was the stupid “Center Focus”, which does nothing for sound bars. I can turn it on and off in real time and it goes from *Burn this device* to *wow, it can sound amazing*.  I suggest you try the same. Keep GG on and flick Center Focus.  Play some music and test it out. I can’t tell you how many times I was gonna return this thing.  I just couldn’t pin point if it was something I was doing wrong or not.

How Razer has never posted something around this tells me they suck at testing real bad. SO MANY PEOPLE WASTED SO MUCH TIME ON THIS. 

For others out there, you can also bypass the issue in Windows 11 by setting the *Audio Enhancements* to *Off*. It will prevent synapse from interjecting. Although, you lose all Synapse functionality. This is how I got around the terrible quality and EQ’s it was providing before I turned off Center Focus. My god. I don’t get mad easily, but almost a year now and they haven’t picked up on it. 

I’m having the same issue. It just started this evening. I’m getting frustrated with the whole thing. It hasn’t worked properly since Feb 16th. I’ve been going back and forth with Razer support and they just want me to send synapse logs. Whatever happened to tech support staying on the line with you to help.

Had the same problem. Simple solution was the repair function on windows 11.

I just bought the Leviathan V2 and out of the box their was almost no bass, and fiddling with the synapse equalizer made no difference one way or the other.  After fiddling around all morning I found the culprit at least for me, posting here for any under same circumstance to try.


I found that my Synapse/Leviathan wasn’t getting along nicely with the SteelSeries GG app for my SteelSeries headphones.  Basically, if the GG app loads with the Leviathan turned on, the sound goes to junk.  So from now on, I have to block GG from starting in Windows, and when wanting to use my headphones I have to make sure to turn off the soundbar first so it disconnects from Synapse, then turn on the GG app.  And of course completely exit the GG app before turning back on the Leviathan soundbar.


So if you happen to have a quality headset or other sound device with a supporting app and have a sound quality issue with your Leviathan, following the above hopefully will help you.


Also, like what has already been mentioned, the “Center Focus” Synapse setting has to be left off for me as well for decent bass to kick in.

Extremely disappointed.  I FINALLY got my Leviathan working with the Synapse… THX Spatial and all that jazz… But I should have just saved my money for the X version that doesn’t come with a sub since this one doesn’t even push out to the sub at all!  It’s like it wants the bar to be the sub, and that’s not what I spent my money on.  This is a driver/software issue.  If Razer doesnt want to fix, then I doubt that I’ll by the Nommo Pro V2 especially if it is THX Spatial.

Just try one thing you could try is checking the connection between the subwoofer and the main unit. Make sure the cable is securely plugged in on both ends and that there are no loose connections.

If the connection looks good, you may want to reach out to the manufacturer's customer support for further assistance. They may be able to offer some additional troubleshooting steps or even a replacement if the subwoofer is found to be defective.

awesomeSHELL Yes the “Center Focus” is awful and needs to be left off but I definitely also have an issue with the Virtual output devices that load up with Steelseries GG.  Bottom line is if Windows loads these virtual audio devices when starting, the subwoofer for the Leviathan V2 does not kick in as it should.

i went thru this for two weeks with 13 different replies and 13 different support people in the end the same reply sorry youre out of warranty ( 2 months) cant help but if you sign up for our newsletter we'll give to $10 off worst customer experience ive ever had the buttons dont work!! so i cant trouble shoot anything and trying various ports & cords didnt help. this is obviously a huge issue with all the posts ive seen im done with Razer & will tell everyone i know

To get my sub working again, Went into sound properties => playback => Select Razer Leviathan V.2 => Properties => Advanced Tab => Uncheck “Enable Audio Enhancements” => Apply Sub started working as soon as I hit Apply!

Cult of Razer 4 Life!


my friend talked me into getting razer I finally caved and bought the razer leviathan v2 and it's been trash, every problem you can think of it has… will follow my instincts and never buy razer again.
I'm only 26 but damn I miss the old days when you just plugged a damn speaker in and that's it… no hardware and Sofware issues, this is honestly ridiculous.

I figured out a solution. It may or may not work for the rest of you but uninstalling Razer Chroma did the trick for me. The subwoofer straight up wasn’t connecting for me so I decided to repair Chroma and during the repair process, the subwoofer reconnected at full volume but once Chroma was done repairing it disconnected. I decided to just uninstall it after that. I wasn’t a big fan of Chroma to begin with

No subwoofer sound from mine either.  If i could return this trash i would.  Unfortunately I'm overseas and shipping it put it out of the return window.  Razer needs to do better.  

Same. My subwoofer has no sound, but I can see the vibration. I'm thinking that it's a driver issue. No idea how to fix it