Razer Basilisk V3 Pro not charging/working | Razer Insider
Question

Razer Basilisk V3 Pro not charging/working

  • 11 February 2024
  • 12 replies
  • 671 views

I recently purchased the Basilisk V3 Pro with the wireless charging station. I’ve had it for about 2 weeks now. When I first got it, I had a hard time getting it to charge wirelessly but after unplugging the doc and reinserting the puck, it started to work. 

 

2 days ago, it was to about 4% battery so I put it on the charger during my break and it charged up a bit. The dock lit up red and went up to about 10%. All good there. I finished my workday and put it back on the charger. Again, it lit up red like it was charging. I left it alone and when I went to use it today, the dock was cycling through the colors and the mouse is unresponsive. I have unplugged and replugged the dock, removed the charging puck, cleaned the pins, and put it back on the charger. Nothing. So I plugged it in via USB to my computer to try that. Again, nothing. I have also tried the reset with the left, right, and center buttons but it didn’t do anything either. I’m fairly confident its completely dead since it was back down to 4ish% at the end of my workday and I guess it never actually charged. I have no idea if it is completely up to date but I can’t apply any update to it if it isn’t because it isn’t connecting to my computer. I have even tried plugging it in via USB to another computer that has never interacted with this mouse and still nothing.

 

I have also read other articles about issues with purchasing from Best Buy so I guess it is worth mentioning that I purchased these directly from the Razer store.

 


12 Replies

So I’m having the same issue, bought the mouse I think about a month ago and have loved everything about it. Today I left to go check some things away from my computer, the mouse was low and blinking red but I just didn’t plug it in. Came back about 45 minutes later and the mouse will not respond, does not get recognized by the computer when plugged into any of my functioning motherboard USB ports, and is just entirely unresponsive. Wanted to try your solution before trying to RMA this, when you say “Update (02.13.2024)” do you mean firmware for razer products? I’ve never had to do that before and I just tried through the https://mysupport.razer.com/app/answers/detail/a_id/4166/~/software-and-firmware-updates-for-razer-peripherals and it won’t recognize the mouse and so it cannot update the mouse. Dongle did get recognized though.

So I’m having the same issue, bought the mouse I think about a month ago and have loved everything about it. Today I left to go check some things away from my computer, the mouse was low and blinking red but I just didn’t plug it in. Came back about 45 minutes later and the mouse will not respond, does not get recognized by the computer when plugged into any of my functioning motherboard USB ports, and is just entirely unresponsive. Wanted to try your solution before trying to RMA this, when you say “Update (02.13.2024)” do you mean firmware for razer products? I’ve never had to do that before and I just tried through the https://mysupport.razer.com/app/answers/detail/a_id/4166/~/software-and-firmware-updates-for-razer-peripherals and it won’t recognize the mouse and so it cannot update the mouse. Dongle did get recognized though.

That was the date I made the comment. I think the connection issue happens if the mouse completely dies but I could be wrong. My initial thoughts would be to plug it into the wall for now to make sure it charges up. Then uninstall the Razer apps to try to force it to recognize and reinstall what it needs with the latest versions. 

Lmao that makes more sense, IDK how I read it that way but I’ll give that a shot, appreciate it.

Contacted Razer and they have no solution besides RMA.  JFYI for those still experiencing flaky or no charging.

You are absolutely not alone in this. I have exactly the same problem, just without a charging station. But what shocked me is how many people generally have problems with loading the mouse. Unfortunately, I no longer have a receipt for mine and the company I bought it from went bankrupt almost a year ago. Now I will probably switch to another manufacturer again.

Ive done the latest firmware update, checked everything I could think of.  It will not charge.  So the extra money i paid for a wireless mouse is wasted as it has to be plugged in to use.

Ive done the latest firmware update, checked everything I could think of.  It will not charge.  So the extra money i paid for a wireless mouse is wasted as it has to be plugged in to use.


I contacted support and they immediately sent me a new base and puck with very few questions which leads me to believe they have a known quality issue. 
 

So far, it has mostly worked. It did stop charging the other day but turning off the mouse and charging via USB overnight seems to have corrected it. 
 

Typical Razer quality…

Same problem here.  Near as I can tell, it has never been charging on the base station and finally drew down its battery from its first charge.  If I pull up Synapse and dock it, the charge icon is shown in Synapse for a less than a minute, while the mouse glows red, then the charge icon goes away and the mouse goes back to whatever color profile I had loaded.

 

I have had so many problems with anything battery powered from Razer that this will be my last Razer purchase.

Exact same problem.  Got mine in January and it no longer charges. I’ll try the update

Same problem here.  Near as I can tell, it has never been charging on the base station and finally drew down its battery from its first charge.  If I pull up Synapse and dock it, the charge icon is shown in Synapse for a less than a minute, while the mouse glows red, then the charge icon goes away and the mouse goes back to whatever color profile I had loaded.

 

I have had so many problems with anything battery powered from Razer that this will be my last Razer purchase.

 

I haven’t had issues after I uninstalled and reinstalled. The only thing is it wont charge if my computer goes to sleep which is a bit annoying but otherwise works fine.

Exact same problem.  Got mine in January and it no longer charges. I’ll try the update

I haven't had any issues with it since I updated it. :)

Update (02.13.2024): After just leaving it on my desk in the off state since creating this thread, I decided to plug it in again via USB and it turned right on at 100% and seems to be working fine for right now (even via 2.4 wireless). I’m glad its working again but not super reliable at this point.

Reply