Razer Blade 15 Advanced 2020 not silent anymore. | Razer Insider

Razer Blade 15 Advanced 2020 not silent anymore.

  • 16 August 2020
  • 3 replies
  • 123 views

Hey, a few days ago I got the new Blade 15 advanced full spec model. I love it. And it was always completely silent when it was under no load or I was browsing or watching netflix. I contacted the Razer support because I had an issue that I could not watch netflix in 4k with this machine (still unsolved) but while at it we disabled the graphics card (2080 super max q) in the device manager settings. And after that the blade was never to be silent anymore. Now the fans are like jet engines even if I'm just on the desktop and having nothing open. I tried to restart it, update the nvidia software and even recovered the whole system since it was no issue I haven't installed everything I needed yet anyway. But even after a full recovery when I start the laptop and have the synapse setting on balanced the fans are just always running no matter what. On load, of course, but I closed every single program and after a while on the desktop the fans are still running. I expected the Blade to be completely silent all the time except of course under heavier loads. I have the 2080 super max q version with a 4k screen from 2020. Am I the only one experiencing this issue? How about you, are your laptops completely silent when browsing or doing light work? Because they should be. This is so frustrating for me, I expected something else from such an expensive laptop.

Are your Blades 15 advanced from 2020 silent when idling or browsing?


This topic has been closed for comments

3 Replies

mine is not that noisy but i do have the netflix issue.. no 4k..so you did not resolve the issue?
I'm getting the same issue on an identically speced Razer Blade Advanced 15 inch.
make sure the power profile is in balanced mode. If you have it in High Performance mode it will run hotter. Also check Synapses and see if the fan profile is set to Auto or manual and that you have not set it to a stilly high RPM.

If you also delve into the power settings, check the fan cooling profile on battery is set to passive and not active.