Razer Ripsaw HD PS5 Doesn't Work | Razer Insider

Razer Ripsaw HD PS5 Doesn't Work

  • 15 November 2020
  • 5 replies
  • 1663 views

So as exciting as it is that I just hooked up my PS5 after playing awhile I decided to hook it up through my Razer Ripsaw HD, in doing so I have just a black screen, tried unplugging it, restarting pc, checked both HDMI cords the one that came with the pc and the razer hdmi that came with the ripsaw, both worked from ps5 to monitor, I can find nothing online about it saying it doesn't work, everything says it should work and recommends it, anyone have anythoughts cuz I am at a loss and now for streaming I must use just my PS5 which negates everything I have setup in SLOBs.

This topic has been closed for comments

5 Replies

Try this in your settings... System -> HDMI -> and disable your HDCP.

This will prevent Netflix, and other apps from working but should let you see you in slobs.
Great suggestion since that worked on PS4, however I've tried this and still have a black screen like Plastikwired.
I am having the exact same issue. I just purchased the Razer Ripsaw, it works on PS4, Switch, Wii U, and yes, I have HDCP disabled, just a black picture 😞 I also have a Magewell capture card but I like to keep that hooked up to my retro consoles for speed running. Just for the sake of it, I tested the PS5 on Magewell and that worked fine, so it looks like the issue is with the Razer Ripsaw. Looks like I may have to return it 😞
I had a similar issue - I wanted to record the Boot Sequence - you know the one you only see once........Yep Black Screen!!!!

I bypassed the Ripsaw and went HDMI straight into the Monitor, then disabled the HDCP setting, and then plugged it back into the Ripsaw - now I had a picture but no sound....fixed that by running a 3.5 mm headphone cable from the PS5 Controller into the Ripsaws Microphone port....

Not happy about having to be that close to the screen, I ordered some new HDMI cables - 2.1 8K Ultra HD ones.....and now I have sound going through HDMI/Ripsaw into SLOBS
TheLymey
I had a similar issue - I wanted to record the Boot Sequence - you know the one you only see once........Yep Black Screen!!!!

I bypassed the Ripsaw and went HDMI straight into the Monitor, then disabled the HDCP setting, and then plugged it back into the Ripsaw - now I had a picture but no sound....fixed that by running a 3.5 mm headphone cable from the PS5 Controller into the Ripsaws Microphone port....

Not happy about having to be that close to the screen, I ordered some new HDMI cables - 2.1 8K Ultra HD ones.....and now I have sound going through HDMI/Ripsaw into SLOBS



Just a note - make sure you are using the PS5 HDMI from the PS5 into the Ripsaw - I used the Razer one and it didn't work....