Ripsaw HD audio popping/tapping | Razer Insider

Ripsaw HD audio popping/tapping

  • 25 January 2021
  • 11 replies
  • 557 views

I'm getting a tapping noise coming through my ripsaw HD. When I pass through to the monitor the sound is gone. But when I listen to the ripsaw audio through OBS or even just listen to the output in the recording section of windows sound control I can hear the constant tapping. I have tried taking everything off the USB board to see if it was to much, but that didn't help at all. I'm lost at this point and considering getting a different card altogether. Any help?

This topic has been closed for comments

11 Replies

Userlevel 7
I can advise few options

  • try plugging a different headset / audio to the Ripsaw HD
  • Try implement the firmware again from the support firmware website
So I can hear the tapping through desktop speakers/headphones etc. But It's crystal clear if I listen to the game through the monitor. It's the actual ripsaw itself that's making the tapping, because OBS records/streams with it, but also if I listen to the device in the sound control panel directly I can hear the tapping. I did just update my firmware after you suggested, but it didn't fix the issue.
Userlevel 7
I tried searching for youtube or any references to the Ripsaw HD tapping.
If the inside of the RipSaw is making the tapping, than I'm thinking~~~

  • Internal hardware damage
  • Or cable issue

For first option you'll need to take the device to a RAZER electronics specialist
Second option, see if you got a spare cables and try swap out~~~

That is all I can suggest

Unless other Insiders can speak otherwise~~~
Ok, How would I contact or find a RAZER electronics specialist?
Userlevel 7
WhiteSmoketoolsquick933
Ok, How would I contact or find a RAZER electronics specialist?

RAZER electronics specialist, I'm talking anyone, like "electronics specialist", "tech dude"

The only reason why I say "RAZER electronics specialist" is so that you do not take it to some random specialist, but a person that really knows their staff about electronics.
Gotcha, thank you very much for the help.
Userlevel 7
Otherwise, you can check out the RipSaw HD support here, and contact a RAZER support
I had the same issue.

I fixed it moving USB port on the PC from USB 3.1 Gen 2 Type A to USB 3.1 Gen 1 Type A.

Hope this helps
hello,i have a ripsaw for stream with my ps4,i have the astro headset A40 With mixamp and when go in obs,audio is distorted and much high,do you fix a problem?
pulsexSilverSand615
hello,i have a ripsaw for stream with my ps4,i have the astro headset A40 With mixamp and when go in obs,audio is distorted and much high,do you fix a problem?


I solved going into Open Sound Settings (in bottom right of windows) -> Sound Control Panel -> Recording -? Razer Ripsaw HD HDMI -> Levels and placed 50 instead of 100
i solved with refound the ripsaw and buy a elgato 🙂