Razer Viper Ultimate doesnt charge | Razer Insider
Question

Razer Viper Ultimate doesnt charge

  • 1 August 2023
  • 8 replies
  • 976 views

My Razer Viper Ultimate just won't charge, it doesn't charge more than 2%, I've tried charging using the dock, I've tried via USB, every way, I've cleanly reinstalled synapse, I've updated firmwares, I've restarted the computer, changed place USB, NOTHING WORKS. I need urgent help, I need mouse functionality, however, I bought it wirelessly to use it wirelessly, I don't use it charging with a wire attached to it.

 

 

 


8 Replies

Userlevel 7
Badge +1

As told earlier it may be a bug in Synapse. But it may be also battery issue.

Depends how long your mouse is working from charging (try to charge it at least for 3h via cable)

I had a same issue. It fixed for me just in some day, but now it returned from nowhere again.

So it’s stucked at 2%?

I’d try to use it till battery dies (0%), and try to charge it again. It just may be some strange bug in Synapse, that it’s showing wrong battery percentage.

now it doesn't load more than 0%

But how long it works at “0%”?

5-15 minutes? 1-2 hours?

stays hours and hours at 0% and does not come out of it.

Userlevel 7
Badge +1

So it’s stucked at 2%?

I’d try to use it till battery dies (0%), and try to charge it again. It just may be some strange bug in Synapse, that it’s showing wrong battery percentage.

now it doesn't load more than 0%

But how long it works at “0%”?

5-15 minutes? 1-2 hours?

I've already checked the USB ports and I'm using the USB that came with the mouse, so I don't know what to do, there's no reset button on the mouse.

Userlevel 2

Same happened to me but with the Naga v2 pro mouse...It won’t charge. It suddenly came back to life and started charging but only at 3% it stopped and started losing charge again… Even when Synapse says it is charging. Now it’s dead again.

So it’s stucked at 2%?

I’d try to use it till battery dies (0%), and try to charge it again. It just may be some strange bug in Synapse, that it’s showing wrong battery percentage.

now it doesn't load more than 0%

Userlevel 7
Badge +1

So it’s stucked at 2%?

I’d try to use it till battery dies (0%), and try to charge it again. It just may be some strange bug in Synapse, that it’s showing wrong battery percentage.

Reply