Razer Gold Failed to Reload Error Message

Discussion in 'Razer Gold & Silver' started by Zimaronn, Nov 9, 2021.

Tags:
Thread Status:
Not open for further replies.
  1. Zimaronn

    Zimaronn New Member

    I've been trying to reload my razer gold all day and cannot get past the "Failed to reload" error. I've already submitted a ticket but no response. It's not a problem with my card or bank or anything since I never even get there. Sometimes it fails right when I click "Next" after entering the amount of Razer Gold I want to buy, ex. 100, and sometimes I get the error message after passing the 2FA. I've tried every single payment method I have available to me: Amex, VISA, PayPal and the issue is there for all of them. I've tried Chrome, Firefox, IE, Edge and they all have the exact same issue. I've turned off all adblock, I've tried relogging, rebooting and still nothing.
     
  2. BenanaBred435

    BenanaBred435 New Member

    Same issue here. Submitted a ticket and still waiting for some kind of response.
     
  3. NutraliteZ

    NutraliteZ New Member

    glad I'm not the only one experiencing this... I just hope that all the transactions that failed to go through the first time won't get charged again.
     
  4. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    Hey guys! While I have no visibility over this part of our System, I can try to tap someone to help with your tickets. You can also contact our Razer Gold Team via Live Chat to get this sorted out in real-time. Please send me your ticket number via PM.

    *Thread locked and moved to Gold and Silver boards for visibility.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >