Kraken Tournament Edition - Low volume on headset ONLY | Razer Insider

Kraken Tournament Edition - Low volume on headset ONLY

  • 23 July 2021
  • 1 reply
  • 10 views

Good day!

I recently bought them, plugged on the PC the USB module, installed Synapse, but there was no audio at first, tinkered with options while having some music to check in which device the audio was comming.

Suddenly, the audio came out, but EXTREMELY low...

Again, maxed every sound level on the system and programs and the sound was still too low...

Tryed connecting the Sennheiser GS300 headset on the Kraken's USB module and the sound was playing as expected.

Connected the Hyper X Cloud Revolver S headset only to the USB module and worked fine.

Connected the 3 headset to cell phone and everything went OK except for the Kraken... the sound was still too low with cell phone on max volume

This means I have a deffective headset?

I'll really appreciate any help.

Have a nice day guys!

This topic has been closed for comments

1 Reply

Userlevel 7
RadiCalvo
Good day!

I recently bought them, plugged on the PC the USB module, installed Synapse, but there was no audio at first, tinkered with options while having some music to check in which device the audio was comming.

Suddenly, the audio came out, but EXTREMELY low...

Again, maxed every sound level on the system and programs and the sound was still too low...

Tryed connecting the Sennheiser GS300 headset on the Kraken's USB module and the sound was playing as expected.

Connected the Hyper X Cloud Revolver S headset only to the USB module and worked fine.

Connected the 3 headset to cell phone and everything went OK except for the Kraken... the sound was still too low with cell phone on max volume

This means I have a deffective headset?

I'll really appreciate any help.

Have a nice day guys!


The headset may be faulty. Have you tried connecting the headset directly to a portable device such as a laptop, smartphone, or tablet using its 3.5mm jack? Please update its firmware and see if it helps. Feel free to submit a case to our Support Team or send me a PM should you need additional assistance. I’ll be locking this thread now.