Kraken V3 Pro Hyperspeed Multiple devices doesnt work. | Razer Insider

Kraken V3 Pro Hyperspeed Multiple devices doesnt work.

  • 31 December 2021
  • 1 reply
  • 91 views

I have Razer Kraken V3 Pro and Black Widow V3 Pro and Naga Pro. I have not tried the Naga yet but I have the Black Widow installed via Dongle in 2.4ghz hyperspeed mode and using the pairing utility via synapse but the app will not find my Kraken V3 Pro headset and I specifically bought all hyperspeed compatible devices so I can use only one USB port.

Does anyone know what I am doing wrong? I am pressing and holding a button, the pairing button on the Kraken or so I thought. It will not find it or connect unless I use the provided Dongle. I did use it once and restarted the PC hoping it would work but it still does not work when I take the Kraken dongle out of the USB port.

This topic has been closed for comments

1 Reply

Userlevel 7
Gromzz
I have Razer Kraken V3 Pro and Black Widow V3 Pro and Naga Pro. I have not tried the Naga yet but I have the Black Widow installed via Dongle in 2.4ghz hyperspeed mode and using the pairing utility via synapse but the app will not find my Kraken V3 Pro headset and I specifically bought all hyperspeed compatible devices so I can use only one USB port.

Does anyone know what I am doing wrong? I am pressing and holding a button, the pairing button on the Kraken or so I thought. It will not find it or connect unless I use the provided Dongle. I did use it once and restarted the PC hoping it would work but it still does not work when I take the Kraken dongle out of the USB port.


Please check this article. Only the Razer DeathAdder V20 Pro, Naga Pro, and BlackWidow V3 Pro use the HyperSpeed Multi-device dongle. I’ll be locking this thread now. Feel free to send me a PM anytime or visit our self-help options should you have other questions or concerns.