Razer phone original no service | Razer Insider

Razer phone original no service

  • 29 June 2019
  • 4 replies
  • 200 views

I purchased a razer po hine about six months ago and I love it. Yesterday I walked into a factory that i couldnt get service in. When i walked out my phone didnt have service still so I restarted it. Still no service, so I went to att and got a new sim card. After several restarts I did a factory reset. Nothing seems to work. Does anyone have any suggestions?

This topic has been closed for comments

4 Replies

Userlevel 7
VividAuburngardenbest782
I purchased a razar phone and it worked using the sims card until the device was updated to Andriod 8.1. Now I have tried many different sims and the phone will not connect to a mobile network. I have seen many others complaining about similar issues has there been a fix for this?


Have you tried factory resetting your phone and see if the issue persists? Also, have you tested your sim cards to a different phone and check if there's no mobile network issue too?
Razer.Speedcr0ss
Hi @PinkLacefocussmart700!We appreciate that you have posted your concerns here in our support board and the isolation steps you've done too. Where did you buy your Razer Phone? Is it locked with a particular carrier? Is the phone getting a good cellular connection/service before? Was there any hardware or software changes before the issue start?

Hey @vaultgirl83. We appreciate the isolation test that you've done too. Does the issue persist on your Razer Phone 2 after performing a factory reset?

Note: Please send me a PM if you have contacted our Support Team via chat and email together with your case ID or email address.

I purchased a razar phone and it worked using the sims card until the device was updated to Andriod 8.1. Now I have tried many different sims and the phone will not connect to a mobile network. I have seen many others complaining about similar issues has there been a fix for this?
Userlevel 7
Hi @PinkLacefocussmart700! We appreciate that you have posted your concerns here in our support board and the isolation steps you've done too. Where did you buy your Razer Phone? Is it locked with a particular carrier? Is the phone getting a good cellular connection/service before? Was there any hardware or software changes before the issue start?

Hey @vaultgirl83. We appreciate the isolation test that you've done too. Does the issue persist on your Razer Phone 2 after performing a factory reset?

Note: Please send me a PM if you have contacted our Support Team via chat and email together with your case ID or email address.
I am having this same issue on my Razer phone 2, it started over a week ago after a trip in upstate NY where I had little to no service, noticed in Airport on trip home NO SERVICE and it has stayed that way. I've talked with Verizons Tier 2 tech support and they are stumped. Contacted Best Buy where I purchased my phone 2/1/19 directed me to Razer for warranty. Literally everything else is working fine. Verizon sent me a new sim and no go still no LTE or SMS service. Tested my sim in a spare samsung 7 and it works fine. Seems to be more like the internal Sim/Storage card "reader" is not "reading" or detecting the cards in tray for no good reason.