PSA: Bad audio quality with THX turned on while using a custom EQ? (Nari / Essential / Ultimate) | Razer Insider

PSA: Bad audio quality with THX turned on while using a custom EQ? (Nari / Essential / Ultimate)

  • 13 January 2019
  • 4 replies
  • 927 views

Userlevel 3
Turns out there may be an issue with THX Surround Sound and Synapse's EQualizer. The issue makes so, if you're listening to some Surround Sound application (for example, a game), and you pause it; if you resume it, the sound will come back muffled.

It seems to only happen if you have THX Spatial Sound activated, playing or listening to a Surround Sound app or game, and if you have a custom EQ curve.



This completely destroys the audio quality when this happens. After some long talks with support yesterday, I think I've accidentally come across a solution that does not involve sacrificing either your EQ settings or THX Surround Sound.


  • Create a blank profile within Synapse and calibrate THX Surround Sound (it's the same as "Spatial Audio", so gonna go with Surround to avoid confusion).


  • Turn THX off, making every single source Stereo automatically.


  • Now introduce the EQ settings that you may like. In my case, I've found these to be the best EQ settings if you want the flattest-frequency response (from left to right): 4,4,8,0,-6,-3,3,-6,8,8.


  • Duplicate the profile.


  • Now, on the new profile, you can turn THX back on.


  • DO NOT DISABLE THX EVER AGAIN IN THIS NEW PROFILE, OR TOUCH THE EQ SETTINGS. You can still choose which apps will use THX and which ones will be rendered in Stereo from the "Mixer" tab, though.


You will still be able to choose which apps are to be rendered in either Stereo or Surround Sound, just don't toggle the button at the top that says "THX SPATIAL AUDIO" or go into the EQ settings. I don't know if switching back to the original profile may cause trouble, so I'd advice against that once again.

As a last consideration, make sure the quality of the playback and recording devices linked to the Nari are set to the highest possible quality in the Windows' Sounds panel (right click on the audio icon in the Windows Taskbar and go to "Sounds").

This topic has been closed for comments

4 Replies

Thanks for taking the time to post your solution. I have the Kraken TE with the DAC for THX and have toggled it on and off a few times and not noticed this exactly as you described. I do; however, notice strange behavior in overall sound reproduction and max volume from time to time (even with the in line mic up all the way). It's almost like one day it sounds fine and the next it's constrained.

You mention it with the Nari as well which makes me pause on that purchase. I'm going to try your solution and see if there is a difference on my end too.

Thanks for posting and doing the troubleshooting!
Userlevel 3
imReqi
Thanks for taking the time to post your solution. I have the Kraken TE with the DAC for THX and have toggled it on and off a few times and not noticed this exactly as you described. I do; however, notice strange behavior in overall sound reproduction and max volume from time to time (even with the in line mic up all the way). It's almost like one day it sounds fine and the next it's constrained.

You mention it with the Nari as well which makes me pause on that purchase. I'm going to try your solution and see if there is a difference on my end too.

Thanks for posting and doing the troubleshooting!


You're most welcome; from what I've experienced, doing what I describe in the post has fixed the issue permanently for me; even after restarting and turning the PC on and off. So for the time being, I wouldn't worry about this particular issue, and even then, it's entirely on the software side of things.

Putting this software issue aside, I haven't had any problems with the Nari Ultimate whatsoever (apart from the left LED being sliiightly more purple-ish than the right one, but hardly a deal breaker considering it is only noticeable when the color is set to "white", and even then they're both still white, just different temperatures of white). Then again I have had it for only a couple of days, but I don't see it giving any more issues unless some future software update screws everything up.

Considering that both the Kraken TE and Nari headsets use the exact same implementation of THX Spatial Audio, wouldn't surprise me at all if similar problems arose in both models.

Hoping that maybe some similar steps to what I've posted may help you with your Kraken TE situation.
Hello guys,

did you get any answer from official tech support, if this issue will be fixed in future Synpase updates?

Today I turned on my computer and when I tuned on some music, my sound from Nari was really strange, like muffled or what. When I turned on and off THX sorround, the sound returned according to the EQ setting.

Thanks for info.

EDIT: This strange behaviour occurred even when I turned off game with custom profile with THX enabled. I have secondary - my main profile (Windows profile - with stereo output but THX enabled.) and when I turned on music, muffled sound occurred once again. Funny fact is, that I only pressed mixer button and sound switched to “correct one” automatically. So this is clearly a software issue.
Userlevel 3
Try out this solution: https://www.reddit.com/r/razer/comments/b6qny8/razer_nari_ultimate_guide_to_nondistorted/