Dedicated GPU not working on 2022 Blade with 3080ti 240hz QHD | Razer Insider
Question

Dedicated GPU not working on 2022 Blade with 3080ti 240hz QHD

  • 21 April 2023
  • 2 replies
  • 127 views

Hello community,

On my Razer Blade (i7, 32GB RAM, 3080Ti, 240Hz QHD) the dedicated GPU doesn't seem to be working properly. A friend who has the same device gets an average of 80fps in benchmarks (3DMark) while I only get 11 FPS. 
What is noticeable though is that the CPU also drops in scores on my device. I assume this is because the graphics calculation is only done by the CPU and not the GPU.
Also, my Blade doesn't get nearly as hot as his. I have now rebooted the device several times, reinstalled windows serval times, removed drivers, installed only the Windows drivers, installed only the Intel drivers, installed only the Nvidia drivers or install all drivers together. None of these have resulted in any change. Also games like CSGO or MW2 have way too little FPS. What I also noticed:
- I cannot open the Nvidia Control Panel. It simply does not start.
- in Geforce Experience it always shows that there is a driver to install, but after installation the info doesn't disappear and I could reinstall the driver endlessly
- If I change the BIOS to GPU Only, the monitor shows nothing and I have to reset the BIOS blindly.
- In Synapse I am not even offered to switch to GPU only mode. This seems to be due to the 240hz QHD display (my device is not in the list of GPU Only devices https://mysupport.razer.com/app/answers/detail/a_id/4029/~/which-razer-blade-models-have-a-dedicated-gpu-only-gpu-mode%3F).

Is there anyone here who has the same device and has had similar experiences? The Razer Support is also informed but couldn’t help me yet.


2 Replies

You have a Razer Blade laptop with an i7 processor, 32GB of RAM, 3080Ti graphics card, and 240Hz QHD display. However, you are experiencing significantly lower FPS compared to a friend who has the same device. You have tried various solutions, including reinstalling Windows and drivers, but the issue persists. You also cannot open the Nvidia Control Panel, and Geforce Experience always shows a driver to install. Additionally, changing the BIOS to GPU Only results in a blank monitor, and Synapse does not offer the option to switch to GPU Only mode. You have contacted Razer Support but have not received a solution yet. You are seeking help from anyone who has experienced similar issues. 

You have a Razer Blade laptop with an i7 processor, 32GB of RAM, 3080Ti graphics card, and 240Hz QHD display. However, you are experiencing significantly lower FPS compared to a friend who has the same device. You have tried various solutions, including reinstalling Windows and drivers, but the issue persists. You also cannot open the Nvidia Control Panel, and Geforce Experience always shows a driver to install. Additionally, changing the BIOS to GPU Only results in a blank monitor, and Synapse does not offer the option to switch to GPU Only mode. You have contacted Razer Support but have not received a solution yet. You are seeking help from anyone who has experienced similar issues. 

Correct.

Reply