razer core x gpu not detected | Razer Insider

razer core x gpu not detected

  • 24 April 2019
  • 4 replies
  • 59 views

hi i have razer blade pro trying to connect razer core x with gpu..my gpu is msi rtx 2080 ti gaming x trio ..i dont seems to get the gpu detected..its fully power and fan and lights are working on gpu...but on pc it wont detcted the gpu...

This topic has been closed for comments

4 Replies

Userlevel 7
I’m guessing you have Blade Pro 4K? If it’s yeah there’s not easy conneting it since I think because of TB3 connection and g sync display technology. Try manually disable your dgpu and run only on external display. I talked with Blade Pro 4K user who tried core v2 but for core v2 there’s gpu switcher that help easier switching gpu, I heard it’s not working with core x but you can try.
I don’t know what I did after installing and Unstalling i manage to run both GPU...yes blade pro 4K..I need to try again later if it will connect it..if not I will follow your suggestion ..
Userlevel 7
Ram3sh
I don’t know what I did after installing and Unstalling i manage to run both GPU...yes blade pro 4K..I need to try again later if it will connect it..if not I will follow your suggestion ..

Note also first installation would take time since intel software try to adapting new hardware. And install same drivers version for both 1080 and 2080ti.
You can try pm @Preystation he has same Blade Pro like you and use egpu (Core v2) Setting.
Joikansai
Note also first installation would take time since intel software try to adapting new hardware. And install same drivers version for both 1080 and 2080ti.
You can try pm @Preystation he has same Blade Pro like you and use egpu (Core v2) Setting.

Ok thank you.i will try to boot the system later and hope to have both gpu working..