1.04 Razer Raiju Ultimate firmware request

Discussion in 'Console Peripherals' started by worldHanBluefirst720, Jan 25, 2019.

  1. BBigBabol

    BBigBabol New Member

    My device is to be replaced after sale. The default is the firmware of V1.1
     
  2. 7nightwing7

    7nightwing7 Active Member

    Wasn't the default firmware 1.0 ,
     
  3. techCORAL138

    techCORAL138 New Member

    Yes, apparently, 1.1 is newer than 1.04
     
  4. 7nightwing7

    7nightwing7 Active Member

    Ok ty. Getting my replacement next week.
     
  5. NooVc

    NooVc New Member

    Hello everyone, I am from Taiwan, my English is not good, I can only use GOOGLE translation. My RAZER RAIJU TE has stick drift, version 1.03. RAZER's service in Taiwan is not so complete, so I need assistance. I know I can't get RMA, so I need v1.04 update to update my RAZER RAIJU TE
     
  6. Clive.c

    Clive.c New Member

    Version 1.04 also has the problem the drift problem is gone but use the wired mode the controller will have delay problem
     
  7. 7nightwing7

    7nightwing7 Active Member

    My previous controller with 1.04 on it worked fine wired. But Bluetooth had lot's of connection problems.
     
  8. Clive.c

    Clive.c New Member

    Delay ?
     
  9. 7nightwing7

    7nightwing7 Active Member

    No losing Bluetooth connection if i was further away then 3-4 meters. Also if an object got in the way, i lost signal. Like playing with an infared controller xD. Receiving my new replacement next week.
     
  10. stavrosmangaros

    stavrosmangaros Active Member

    Got my RMA as well, had v1.04, i can honestly say it was as bad if not worse than the ones i had previously with version 1.01, no joke, it drifted so many times i couldnt count and it wasnt just that it drifted big time casually, it was that the small moments it looked like it lost touch with earth, like tenths of a second where it didnt respond or did really small drift or refused to aim as long as i wanted to, were countless and wireless it was actually unplayable, i thought ok let me try it wireless and it had so much lag it was impossible. If it didnt say v1.04 i would be absolutely sure it was v1.01, it acted exactly like v1.01
     
  11. Clive.c

    Clive.c New Member

    v1.01 wired mode is normal didn't have any delay or drift problem .
     
  12. Clive.c

    Clive.c New Member

    So do you have any problem right now ?
     
  13. stavrosmangaros

    stavrosmangaros Active Member

    yes, i got my RMA yesterday and it had all the problems i described
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >