Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

14" Razer Blade 2017 with Oculus Link

Discussion in 'Systems' started by headDarkCerulean818, Mar 5, 2020.

  1. headDarkCerulean818

    headDarkCerulean818 New Member

    Anyone getting it to work please post your specs and fixes.

    I'm on the latest Windows 10, Nvidia desktop drivers, Oculus software as of March 6th.
    Using the JOTO USB C to USB A 10ft cable.
    The only working USB A port is the one next to the USB C one.
    It detects the Quest correctly however it freezes a few moments after enabling Link on the headset.
     
  2. Brastic

    Brastic Active Member

    I have no issues running the Oculus Rift S on my 2017 Blade Pro. I am using a Cable Matters USB-C (Thunderbolt 3) to DP adapter. I tried a cheap adapter and it did not work. The Cable Matters adapter was expensive, but it worked. Good luck.
     
  3. fielch

    fielch New Member

    Just tried it out and works great on the old Razer Blade! I guess even though the compatibility says 1060 Desktop only, the 1060 used in the Razer must be good enough (I don't think it's a max q).

    The cable I used worked right away, its a usb 3.1 fellowes C to A that I got in Korea, and doesn't seem to exist on the internet, so unfortunately I have no idea how you would get it outside of Korea.
    UPSer
     
    Last edited: Mar 28, 2020
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >