2019 Blade Stealth goes into 'High Performance' power mode without explanation

Discussion in 'Razer Support' started by figrin1, Jul 10, 2019.

Thread Status:
Not open for further replies.
  1. figrin1

    figrin1 Well-Known Member

    Recently I've noticed the battery on my 2019 Stealth will drain very quickly, without any explanation, when I'm just using it for word processing (Synapse set to 'Low Power', keyboard lighting turned off, and screen brightness down low).

    Today I started with a fully charged battery, and after only two hours of typing and lightly browsing the internet, I received a notification that my battery was down to 10%. Because I didn't bring my power adapter with me, this means my work day has come to a screeching halt.

    Out of curiosity, I checked Windows 'Power Options' and saw that my power profile had been set to 'High Performance' instead of 'Balanced'. This profile makes it so that the CPU stays in a heightened power state, which would explain why my battery had drained so quickly.

    The thing is, the Windows High Performance profile is supposed to be hidden by Razer, and I haven't created any custom power profiles to circumvent this. So something else is switching the laptop out of Balanced and into High Performance.

    My suspicion is that Synapse is quietly switching the Windows power profile to High Performance when I tell it to go into 'Creator Mode', and that it's not reverting back to 'Balanced' when I tell Synapse to go into 'Low Power'.

    Wondering if anyone else has experienced this, if someone could verify that Synapse is the culprit, and ultimately if anyone could offer a solution to this so that I won't have to remember to check my power settings every time I use Synapse to switch between Creator and Low Power.

    Cheers
    Figrin
     
    Last edited: Jul 10, 2019
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    It is rather difficult to tell what is causing this at the moment but the Creator mode is supposed to be the High-Performance mode which is why I'm thinking this has something to do with Synapse. Can you try switching to Balanced mode for a day without Synapse running in the background? In any case, please send me a PM with the serial number of your RBS so I can look into possible fixes.
     
  3. figrin1

    figrin1 Well-Known Member

    Thanks for your response, I really appreciate it. I just sat down to do some writing, I'll close Synapse and see what happens.
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    This'll sound a bit cheesy but I'm here when you need me. Keep me posted!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >