Blackwidow Elite Keyboard Problem: Input Holds

Discussion in 'Razer Support' started by DPTShingles, Dec 17, 2020.

Tags:
Thread Status:
Not open for further replies.
  1. DPTShingles

    DPTShingles New Member

    I really like the feel of my Razer Blackwidow Elite Keyboard with green keys, however, since I started using it, there has been an annoying problem. Occasionally after pressing a key and releasing it, the key will rebound like normal, but the input will still be registering. For example, if I am trying to move forward in a game by pressing the W key, my character will continue to move forward after I release the key. I think this may coincide to when I am simultaneously pressing a different key (i.e. if I am holding shift while pressing W), but I am not sure. This problem is inconsistent and difficult to reproduce on command, but it happens often enough where it is both noticeable and very frustrating.

    Wondering if anybody has had the same problem and knows a fix for it, or if I should just return the keyboard, as my old keyboard had no such problem.

    Thanks
     
  2. VirtualMirage

    VirtualMirage New Member

    I have a similar problem. I believe it randomly occurs after using the Ctrl key since I often find it happening after doing a cut and paste shortcut (ctrl+c, ctrl+v) or when doing the find shortcut (ctrl+f). The following key pressed will sometimes "stick" and will continue to input that key until another key is pressed.
     
    DPTShingles likes this.
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey DPTShingles! Thanks for creating this thread. Does the issue happen while the device is connected to a different USB port? Ensure to connect it directly to our computer's port and not through a USB hub. Please replicate the issue by disabling or closing Razer Synapse 3.0. Should the issue persists, please reset the keyboard in your Razer Synapse 3.0 settings and see if it helps.

    Hi @VirtualMirage. Please let me know your keyboard's progress too.
     
  4. VirtualMirage

    VirtualMirage New Member

    How do you go about resetting the keyboard within Synapse 3.0?

    Aside from my lighting profile, I don't have any customizations set on the keyboard and I don't have any macro keys configured.

    Also, this isn't something that is easily repeatable but I do know the keystrokes that I use. It just happened a few minutes ago when I tried to use Ctrl+c to copy an item. It then proceeded to overwrite what I was copying with a non-stop input of 'c' until another key was pressed.

    I also had an instance earlier this morning when working where the Shift key somehow decided to stick and I was unable to right click anything in the window and everywhere I moved my mouse it would try and select/highlight. Unfortunately, this instance wouldn't stop after a key press. I was about to kill the Synapse app to see if it would release the Shift key but I noticed there was a new update available, 3.5.1215.121019. I decided to let the update install, which it did stop the stuck Shift key when it restarted the Synapse application. But even with this latest version, I still experience the random "sticking" key, as mentioned with the Ctrl+c incident above.
     
    Last edited: Dec 18, 2020
  5. VirtualMirage

    VirtualMirage New Member

    I would like to add that I have the following Razer devices currently installed and in use on my machine that are all showing up in Synapse:

    Razer Mouse Dock Chroma
    Razer Base Station Chroma
    Razer Firefly V2
    Razer Basilisk Ultimate
    Razer Blackwidow Elite
    Razer Kraken Ultimate
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for updating this thread. I'm glad that the continuous keypress was resolved by the Razer Synapse update. Please check if the key sticking issue happens while the keyboard is connected to a different USB port or while the Razer Synapse 3.0 is disabled by following the steps here. By the way, please check the reset option in Razer Synapse 3.0 from the screenshot below:


    upload_2020-12-24_11-48-0.png


    upload_2020-12-24_11-48-20.png
     
  7. VirtualMirage

    VirtualMirage New Member

    I don't know if it killing the service to apply an update, which stopped the stuck key for that particular instance, would be called resolving the issue since I don't believe it completely or permanently resolved the main problem.

    I have tried different USB ports before with no difference. The keyboard and its secondary USB cable are both plugged directly into the USB ports on the rear motherboard panel. I am not using an aftermarket USB controller and my motherboard doesn't have any 3rd party USB controllers added to it. All USB controllers are coming from the CPU (AMD Ryzen 9 3900XT) and the motherboard chipset (AMD X570).

    When I get a chance, I will try the keyboard reset and see if the problem returns afterwards.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >