Blackwidow TE V2 lighting randomly turns off

Discussion in 'Console Peripherals' started by Extos_, Mar 21, 2021.

Thread Status:
Not open for further replies.
  1. Extos_

    Extos_ New Member

    I have the Blackwidow TE V2 and sometimes the lights turn off and I have to unplug it and plug it back in. Opening synapse to restart the lighting doesn't work either. Also, I've tried installing fresh drivers and changing USB ports on my PC. Im completely defeated and don't know what else to do about it. If anyone has an idea what might be happening, please let me know so I can get this fixed. Thanks in advance!
     
  2. LaurenAvocado

    LaurenAvocado New Member

    I'm having the same issue as well! Nothing has worked so far sadly...
     
  3. -Mr.Nobody-

    -Mr.Nobody- Well-Known Member

    can you provide more details, im curently having problem with synapse app/chroma studio. maybe i can help you
     
  4. FiszPL

    FiszPL Well-Known Member VANGUARD

    Tried on different PC?
    I assume, that keyboard is not conencted to any USB Hub?
    Check if the cable on the back of the keyboard is not loose. Or try other mini-USB cable (if you have one).
     
    I.Nix likes this.
  5. Savage_Scream911

    Savage_Scream911 New Member

  6. Extos_

    Extos_ New Member

    Honestly, thats all that it does. I do not have it connected to an external port and the cable seems to work fine. It is connected directly to the back of the mobo and have tried different ports. When I go to synapse to try and reset the lighting, it wont let me change anything through the app. In more detail on that, the keyboard shows up but when viewing the lighting tab, it shows as if the lights are still on and cannot be switched to the off position via the app.

    Im not sure if this helps at all but im not sure what other details i can give. If you have anything specific, please let me know! Thanks in advance for the help!

     
  7. -Mr.Nobody-

    -Mr.Nobody- Well-Known Member

    have you tried to follow this step ? https://mysupport.razer.com/app/answers/detail/a_id/1708/
     
    FiszPL and I.Nix like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >