Blade 14 3080 possible GPU failure

Discussion in 'Systems' started by mattymooers, Aug 14, 2022.

?

Dead GPU?

  1. Yes

    1 vote(s)
    100.0%
  2. No

    0 vote(s)
    0.0%
  1. mattymooers

    mattymooers New Member

    I have a Razor Blade 14 (2021 Model) w/ RTX 3080. I’ve had it since about December of 2021, and I am having issues with it now. Typically I use it while connected to an external monitor. The monitor is connected through a USB-C hub, using HDMI. When I turn the computer on, the monitor automatically connects and extends the display. It was working normally for the first part of the day. I shut the computer down for a while, and when I went back to it and turned it on, the external monitor didn’t connect. This was red flag number one. I made sure all the cables were plugged in correctly, and still had the issue. I tried swapping HDMI cables, and plugging the hub into the other USB-C port on the computer. I also tried plugging the HDMI cable directly into the computer, and still nothing. I grabbed my other computer, and plugged it into the monitor, and it came on instantly. Ruling out any issues with the monitor, and the USB hub. Next I went into the device manager, and under the 3080 display driver it was showing there was a problem with the device. It shows error code 43. I checked to make sure the driver was up to date, which it is. I tried rolling back the driver, thinking maybe a recent update messed it up. Issue was still present with the older driver. I also noticed that trying to open the Nvidia control panel, it just refuses to open. And the GeForce experience application shows the buttons to install drivers even though they’re already installed. When doing this installation, either with express install, or custom, it doesn’t go away. Restart the computer and open the application again and it shows to install the drivers again. After messing with this and uninstalling and reinstalling drivers for a couple hours, I decided to do a fresh Windows install. This issue still exists even on a fresh install with default drivers. I tried installing the most up to date drivers, without installing GeForce experience, and no luck. When looking at GPU-Z, it shows both the integrated and discrete graphics. The integrated AMD graphics show speeds, memory, voltage, and everything. However, the Nvidia graphics doesn’t show any speeds, memory or any voltage readings. At this point I am leaning towards a faulty GPU. I’ve submitted a ticket to Razer but have yet to receive a response, so I figured I would post here and see if anyone can throw out some other ideas. If there are any screenshots, or logs that you might need, I can provide. Hopefully someone can help with this or at least confirm that the GPU is dead. Thank you!
     
    -Mr.Nobody- and pancholr like this.
  2. -Mr.Nobody-

    -Mr.Nobody- Well-Known Member

    i am really sorry mate. please PM one of this guy. and make sure u have your receipt, S/N etc ready so they can forward you for better results. There is no solution i can help with if u already fresh reinstall Windows and the issue still pressist.
    @Razer.Speedcr0ss @Razer.Zionzedd
     
    pancholr likes this.
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

  4. JamesHimmerla

    JamesHimmerla New Member

    new Razerblade 14" laptop had hdmi cut out a month ago (son's machine), finally got a chance to see it this weekend, and saw that the gpu wasn't working in device manager (everything was running off integrated graphcis). I ran through typical troubleshooting - attempt to reinstall nvidia drivers (multiple versions), windows reset, etc.

    No luck, nvidia software installs fail partly through reboot, uninstalls (including drivers) through device manager doesn't work either.

    Spoke to tech support, but they weren't too technical, want me to send it in for warranty claim even though I'm pretty confident it is a software/bios issue.

    Since its still functional with integrated graphics (5900hx), may have to wait awhile to actually send it in for warranty (son's college computer). Anyone encounter similar issues with the latest razer blade and have suggestions on trouble-shooting? Could be hardware, but I'm still leaning toward a driver/bios/software root cause. Appreciate suggestions.
     
  5. neils83

    neils83 New Member

    Hey, I'm experiencing the exact same thing. I did what you did as well. Any luck getting it sorted out? I really need help with my Razer Blade 15 too.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >