Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Broken key help

Discussion in 'Keyboards' started by patters78, Mar 16, 2020.

Thread Status:
Not open for further replies.
  1. patters78

    patters78 New Member

    Hi

    Have just got a second hand Razer Blackwidow keyboard RZ03-0286
    It has a broken right arrow key, can this be replaced.

    I have tried disabling the Razer software but problem still continues
    Can i buy replacement switches and re-solder them?

    Cheers
     
    pancholr and 0V3R_K1LL like this.
  2. FiszPL

    FiszPL Well-Known Member

    Yes, you can buy a replacement and resolder it.
    If you've disabled the key in Synapse it should not work in OS.
     
  3. patters78

    patters78 New Member

    Its not disabled in software is set to default.
    Any idea where to buy the switch from
     
  4. FiszPL

    FiszPL Well-Known Member

  5. patters78

    patters78 New Member

    They don't look like the same switches? on the green part mine look like they have side next to the +
     
  6. patters78

    patters78 New Member

    Right i have done the following today.

    Swapped a key over and the right arrow key still don't work
    Used keyboard on another PC with no Synapse running and still not working?

    How else do these things fail so that just one key don't work?

    also the * & - on the number pad are backward ie i press * and get -
     
  7. Amezx__

    Amezx__ New Member

    take the keycap off both of the keys and then swap them.
     
  8. patters78

    patters78 New Member

    For anyone that cares at all or might have a similar issue..
    I have solved my problem by using a jumper wire from the left arrow key see attached image
     

    Attached Files:

  9. Can anyone help me as well please? i just received my viper ultimate from wireless & cannot use it wireless at all. i keep getting a usb error... :slightly_sad:
     
    DRIFT_IT likes this.
  10. FiszPL

    FiszPL Well-Known Member

    Need a screenshot of the error. Are you trying to connect it via some hub? Or directly to motherboard USB port?
    Also plase don't reply in a topic, that is not connected to your problem.
     
  11. brokeboish

    brokeboish New Member

    if u don't want to solder anything, i'd just use the numpad arrow keys
    or remap prtscrn ins home and pgup as arrow keys
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >